aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuke Yelavich <luke.yelavich@canonical.com>2011-12-13 10:56:56 +1100
committerLuke Yelavich <luke.yelavich@canonical.com>2011-12-13 10:56:56 +1100
commit144708e6667818d48e3bbd9403e447079e8a5c56 (patch)
treea6e98b5093a60d4f6c75dd17e633fba28aadc41d /configure.ac
parent685b2fa7a1895809d767c00eca7f9745632106e4 (diff)
downloadlibdbusmenu-144708e6667818d48e3bbd9403e447079e8a5c56.tar.gz
libdbusmenu-144708e6667818d48e3bbd9403e447079e8a5c56.tar.bz2
libdbusmenu-144708e6667818d48e3bbd9403e447079e8a5c56.zip
Add a new property DBUSMENU_MENUITEM_PROP_ACCESSIBLE_DESC, to set an
alternative label for a menu item. This alternative label is only used for assistive technologies such as Orca. It is particularly useful for menu items where an icon is used to present further information to the user, in which case this property can be used to give a textual description of the icon.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ba5cd4b..ed6080e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,6 +73,7 @@ AM_CONDITIONAL([USE_GTK3], [test "x$with_gtk" = "x3"])
AS_IF([test "x$enable_gtk" != "xno"],[
AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(DBUSMENUGTK, gtk+-3.0 >= $GTK3_REQUIRED_VERSION
+ atk
glib-2.0 >= $GLIB_REQUIRED_VERSION,
[have_gtk=yes]
)
@@ -80,6 +81,7 @@ AS_IF([test "x$with_gtk" = x3],
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(DBUSMENUGTK, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ atk
glib-2.0 >= $GLIB_REQUIRED_VERSION,
[have_gtk=yes]
)