aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDennis Schridde <devurandom@gmx.net>2011-09-19 23:39:39 -0500
committerTed Gould <ted@gould.cx>2011-09-19 23:39:39 -0500
commit21afbd946557e93304bdb34199d62594f365799f (patch)
treed54c544620faae8947cfd1f1366c0cbb28fbe612 /configure.ac
parent3ea5f5573cc0f0f34591ee12b92d789bf624d784 (diff)
downloadlibdbusmenu-21afbd946557e93304bdb34199d62594f365799f.tar.gz
libdbusmenu-21afbd946557e93304bdb34199d62594f365799f.tar.bz2
libdbusmenu-21afbd946557e93304bdb34199d62594f365799f.zip
Making it so that the Vala build is optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 895f9f8..e284980 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,7 +140,17 @@ AM_CONDITIONAL(INTROSPECTION_TEN, [test "x$introspection_ten" = "xyes"])
# Vala API Generation
###########################
+AC_ARG_ENABLE([vala],
+ AC_HELP_STRING([--disable-vala], [Disable vala]),
+ [enable_vala=$enableval], [enable_vala=auto])
+
+AS_IF([test "x$enable_vala" != "xno"],[
+ AM_COND_IF([HAVE_INTROSPECTION],,[
+ AC_MSG_ERROR([Vala bindings require introspection support, please --enable-introspection])
+ ])
AC_PATH_PROG([VALA_API_GEN], [vapigen])
+])
+AM_CONDITIONAL([HAVE_VALA], [test -n "$VALA_API_GEN"])
###########################
# XSLT Processor
@@ -228,3 +238,8 @@ AS_IF([test "x$enable_gtk" = "xno"],
AC_MSG_NOTICE([ Gtk: yes (gtk$with_gtk)])
)
+AM_COND_IF([HAVE_VALA],
+ AC_MSG_NOTICE([ Vala bindings: yes]),
+ AC_MSG_NOTICE([ Vala bindings no])
+)
+