aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-04-13 16:23:09 -0500
committerTed Gould <ted@canonical.com>2009-04-13 16:23:09 -0500
commit53b477561da7b49fcf208cf615a42e3b0820c0b8 (patch)
tree3da0050d550ec59a6f1a78301fc649c57cfbe800 /configure.ac
parent7fde4447bc484c9ff2752740e8bb375d3f2df87a (diff)
downloadlibdbusmenu-53b477561da7b49fcf208cf615a42e3b0820c0b8.tar.gz
libdbusmenu-53b477561da7b49fcf208cf615a42e3b0820c0b8.tar.bz2
libdbusmenu-53b477561da7b49fcf208cf615a42e3b0820c0b8.zip
Putting in more gobject based examples and getting all the libraries tied in to make them work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a4ecbe..47f750a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,21 @@ AC_SUBST(VERSION)
AC_CONFIG_MACRO_DIR([m4])
###########################
+# Dependencies - GLib
+###########################
+
+GLIB_REQUIRED_VERSION=2.18
+DBUS_REQUIRED_VERSION=0.76
+XML_REQUIRED_VERSION=2.6
+
+PKG_CHECK_MODULES(DBUSMENUGLIB, glib-2.0 >= $GLIB_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION
+ libxml-2.0 >= $XML_REQUIRED_VERSION)
+
+AC_SUBST(DBUSMENUGLIB_CFLAGS)
+AC_SUBST(DBUSMENUGLIB_LIBS)
+
+###########################
# Lib versioning
###########################