aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-01 10:21:18 -0500
committerTed Gould <ted@canonical.com>2009-10-01 10:21:18 -0500
commit7ffd9f39deaa7897fb3690aa142812640c7be0c8 (patch)
tree5fc6c484410c6409c88115320ad39c7a57a74074 /configure.ac
parenta49f4f63040677937007c411eddbf6533f9d1428 (diff)
parent2ea44010b225b32705ca21fe2a7cf491fc0c1f4f (diff)
downloadlibdbusmenu-7ffd9f39deaa7897fb3690aa142812640c7be0c8.tar.gz
libdbusmenu-7ffd9f39deaa7897fb3690aa142812640c7be0c8.tar.bz2
libdbusmenu-7ffd9f39deaa7897fb3690aa142812640c7be0c8.zip
Adding stuff, mostly debugging info
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0448f80..00085b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,16 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of the default get
AM_GLIB_GNU_GETTEXT
###########################
+# Massive Debugging
+###########################
+
+with_massivedebugging="no"
+AC_ARG_ENABLE(massivedebugging, AS_HELP_STRING([--enable-massivedebugging], [Print out so much information your brain will hurt]), with_massivedebugging=$enableval, with_massivedebugging=no)
+if test "x$with_massivedebugging" = "xyes"; then
+ AC_DEFINE([MASSIVEDBUGGING], [1], [Print everyting])
+fi
+
+###########################
# Files
###########################
@@ -109,5 +119,6 @@ AC_MSG_NOTICE([
libdbusmenu Configuration:
Prefix: $prefix
+ Massive Debugging: $with_massivedebugging
])