aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-30 11:29:46 -0500
committerTed Gould <ted@gould.cx>2010-06-30 11:29:46 -0500
commit9b98c0e29a0f15d9203feb051f4d39155e331dda (patch)
treef8b393f773365af2ac46d51c114f1785ee27aaff /configure.ac
parent9dc2095a918b79246713d205b1716358f5d012ec (diff)
parent94516efaf61bccb441d4c49bb94e4ae5cd86e9ee (diff)
downloadlibdbusmenu-9b98c0e29a0f15d9203feb051f4d39155e331dda.tar.gz
libdbusmenu-9b98c0e29a0f15d9203feb051f4d39155e331dda.tar.bz2
libdbusmenu-9b98c0e29a0f15d9203feb051f4d39155e331dda.zip
* Upstream Merge
* Adding more through JSON support for testing * Autogen * debian/control, debian/libdbusmenu-jsonloader*install: Adding two binary packages for the jsonloader test library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 80c4b8b..598df4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,8 +62,10 @@ AC_SUBST(DBUSMENUGTK_LIBS)
###########################
JSON_GLIB_REQUIRED_VERSION=0.6.0
+GIO_UNIX_REQUIRED_VERSION=2.24
-PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION)
+PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION
+ gio-unix-2.0 >= $GIO_UNIX_REQUIRED_VERSION)
AC_SUBST(DBUSMENUTESTS_CFLAGS)
AC_SUBST(DBUSMENUTESTS_LIBS)
@@ -126,6 +128,7 @@ libdbusmenu-gtk/dbusmenu-gtk.pc
tools/Makefile
tools/testapp/Makefile
tests/Makefile
+tests/dbusmenu-jsonloader.pc
docs/Makefile
docs/libdbusmenu-glib/Makefile
docs/libdbusmenu-glib/reference/Makefile