aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-07-20 16:36:57 -0500
committerTed Gould <ted@gould.cx>2010-07-20 16:36:57 -0500
commitaccf3124c2a994078cf5b2520edcd5f841922c6c (patch)
tree8fd6ea13e4e197326d1f9ac4055e367a7f670bf1 /configure.ac
parent98b3815a25ffcf89f7d5b062bda254f5fcaa1ab2 (diff)
parent70961ba202ced579d434e19f185f442684814722 (diff)
downloadlibdbusmenu-accf3124c2a994078cf5b2520edcd5f841922c6c.tar.gz
libdbusmenu-accf3124c2a994078cf5b2520edcd5f841922c6c.tar.bz2
libdbusmenu-accf3124c2a994078cf5b2520edcd5f841922c6c.zip
Making it so that dbus-dumper has a click to dump feature.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c2400c..93aa557 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,18 @@ AC_SUBST(DBUSMENUGTK_CFLAGS)
AC_SUBST(DBUSMENUGTK_LIBS)
###########################
+# Dependencies - dumper
+###########################
+
+X11_REQUIRED_VERSION=1.3
+
+PKG_CHECK_MODULES(DBUSMENUDUMPER, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ x11 >= $X11_REQUIRED_VERSION)
+
+AC_SUBST(DBUSMENUDUMPER_CFLAGS)
+AC_SUBST(DBUSMENUDUMPER_LIBS)
+
+###########################
# Dependencies - Testing
###########################