aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-02 16:31:22 -0500
committerTed Gould <ted@canonical.com>2009-10-02 16:31:22 -0500
commitbc69362aa594cce5507ae1fbe8132576fb22df3e (patch)
treef92ff07ae143390163f70b88dff16412074b6013 /configure.ac
parentaa94500715e83db9933fabc09f7df188098985b4 (diff)
parenta1b3e6d9400764292ea6f4252e4fa93f98da3c5a (diff)
downloadlibdbusmenu-bc69362aa594cce5507ae1fbe8132576fb22df3e.tar.gz
libdbusmenu-bc69362aa594cce5507ae1fbe8132576fb22df3e.tar.bz2
libdbusmenu-bc69362aa594cce5507ae1fbe8132576fb22df3e.zip
Managing the lifecycle of the menu item more directly and making sure to remove them from the menu when they're not children of it anymore.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0448f80..3e3b4fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,16 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Name of the default get
AM_GLIB_GNU_GETTEXT
###########################
+# Massive Debugging
+###########################
+
+with_massivedebugging="no"
+AC_ARG_ENABLE(massivedebugging, AS_HELP_STRING([--enable-massivedebugging], [Print out so much information your brain will hurt]), with_massivedebugging=$enableval, with_massivedebugging=no)
+if test "x$with_massivedebugging" = "xyes"; then
+ AC_DEFINE([MASSIVEDEBUGGING], [1], [Print everyting])
+fi
+
+###########################
# Files
###########################
@@ -109,5 +119,6 @@ AC_MSG_NOTICE([
libdbusmenu Configuration:
Prefix: $prefix
+ Massive Debugging: $with_massivedebugging
])