aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-11-11 08:26:35 -0600
committerTed Gould <ted@gould.cx>2010-11-11 08:26:35 -0600
commitc083bd5c6cf41d4e618f7e646a8dc60a59f07063 (patch)
tree0b1f87cdb3e1770dff5baa16843d4f36a8c83f5c /configure.ac
parentc9694f168206aec1258a57b0f9e458e2a9485ef0 (diff)
downloadlibdbusmenu-c083bd5c6cf41d4e618f7e646a8dc60a59f07063.tar.gz
libdbusmenu-c083bd5c6cf41d4e618f7e646a8dc60a59f07063.tar.bz2
libdbusmenu-c083bd5c6cf41d4e618f7e646a8dc60a59f07063.zip
Adding in the deprecation flags even if we can't really use them yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2bd8042..71358a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,15 @@ AC_CONFIG_MACRO_DIR([m4])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+AC_ARG_ENABLE([deprecations],
+ [AS_HELP_STRING([--enable-deprecations],
+ [allow deprecated API usage @<:@default=yes@:>@])],
+ [],
+ [enable_deprecations=yes])
+AS_IF([test "x$enable_deprecations" = xno],
+ [CFLAGS="$CFLAGS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGSEAL_ENABLE -DGTK_DISABLE_SINGLE_INCLUDES"]
+)
+
###########################
# GTK Doc
###########################