aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-27 23:40:23 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-27 23:40:23 -0500
commitc54e02d80857bd08071e2311f456ef992a9d7a01 (patch)
tree0fab75522dee9301262840fdaa1dde732b545286 /configure.ac
parent3a9221c21feb1701119db5079bf3e350c0cb0aac (diff)
downloadlibdbusmenu-c54e02d80857bd08071e2311f456ef992a9d7a01.tar.gz
libdbusmenu-c54e02d80857bd08071e2311f456ef992a9d7a01.tar.bz2
libdbusmenu-c54e02d80857bd08071e2311f456ef992a9d7a01.zip
Added gcov coverage tooling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 274875f..f281325 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,6 +193,18 @@ if test "x$with_massivedebugging" = "xyes"; then
fi
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -250,3 +262,7 @@ AS_IF([test "x$have_dumper" = "xyes"],
AC_MSG_NOTICE([ Dumper: no])
)
+AS_IF([test "x$use_gcov" = "xyes"],
+ AC_MSG_NOTICE([ Coverage reporting: yes]),
+ AC_MSG_NOTICE([ Coverage reporting: no])
+)