aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-08-04 16:34:08 +0100
committerTed Gould <ted@canonical.com>2009-08-04 16:34:08 +0100
commitf5c8526e3bb73345242ea37c337562182351020b (patch)
tree432cb5de765f8484daa87646c0a60d3bac6b3f4f /configure.ac
parentec5c382624da19a1a83d1e75d21f74778df01f38 (diff)
parent92f690257a45e81b86b39fc77ce1fe10c7b4908a (diff)
downloadlibdbusmenu-f5c8526e3bb73345242ea37c337562182351020b.tar.gz
libdbusmenu-f5c8526e3bb73345242ea37c337562182351020b.tar.bz2
libdbusmenu-f5c8526e3bb73345242ea37c337562182351020b.zip
Merging in the development branches
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 96b23fc..6a5ed9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,31 @@ AC_SUBST(DBUSMENUGLIB_CFLAGS)
AC_SUBST(DBUSMENUGLIB_LIBS)
###########################
+# Dependencies - GTK
+###########################
+
+GTK_REQUIRED_VERSION=2.16
+
+PKG_CHECK_MODULES(DBUSMENUGTK, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION
+ libxml-2.0 >= $XML_REQUIRED_VERSION)
+
+AC_SUBST(DBUSMENUGTK_CFLAGS)
+AC_SUBST(DBUSMENUGTK_LIBS)
+
+###########################
+# Dependencies - Testing
+###########################
+
+JSON_GLIB_REQUIRED_VERSION=0.6.0
+
+PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION)
+
+AC_SUBST(DBUSMENUTESTS_CFLAGS)
+AC_SUBST(DBUSMENUTESTS_LIBS)
+
+###########################
# Lib versioning
###########################
@@ -70,6 +95,7 @@ libdbusmenu-gtk/dbusmenu-gtk.pc
libdbusmenu-qt/Makefile
libdbusmenu-qt/dbusmenu-qt.pc
tests/Makefile
+tests/dbusmenu-gtk/Makefile
])
###########################