aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-24 14:15:33 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-06-24 14:15:33 -0400
commit9a8c84b879e78aa8e0a9c1759fc5b73a29efd116 (patch)
tree8471f1da76c5592c05fffb462337726c43b81db5 /debian/rules
parent565603d992afa03da6a8f485fcdbe8b71677f7db (diff)
parentb08640dfaa65d54ac758e14f103e92bdc20990e0 (diff)
downloadlibdbusmenu-9a8c84b879e78aa8e0a9c1759fc5b73a29efd116.tar.gz
libdbusmenu-9a8c84b879e78aa8e0a9c1759fc5b73a29efd116.tar.bz2
libdbusmenu-9a8c84b879e78aa8e0a9c1759fc5b73a29efd116.zip
* debian/control, debian/*: Renaming packages for library version
bump from 3 to 4. * New upstream release. * Fixing visibility for Eclipse (LP: #770263 and LP: #618587) * Unseting a GValue properly (LP: #785828) * Memory leaks for GVariant usage (LP: #784890) * Making GTK 3 default build * Removing the SerializableMenuitem object * debian/rules: Making GTK2 the special build * New upstream release. - Fix a typo in the signal name to make it match the XML files (LP: #641209) - Ref'ing the server for the entire time we're getting the bus (LP: #738568) - Watch additions/removals from submenus that get added - Activate new toplevel menu items as they get added - Make sure we don't activate toplevel children that aren't menu items or don't have submenus (LP: #761112)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules36
1 files changed, 18 insertions, 18 deletions
diff --git a/debian/rules b/debian/rules
index dd4f69c..2243a71 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,32 +11,32 @@ DEB_BUILDDIR = $(DEB_SRCDIR)/build
DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper --enable-gtk-doc --enable-introspection
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-configure/libdbusmenu-gtk3-3:: stamp-configure-gtk3
-stamp-configure-gtk3:
- : # configure for GTK+ 3.0
+configure/libdbusmenu-gtk4:: stamp-configure-gtk2
+stamp-configure-gtk2:
+ : # configure for GTK+ 2.0
set -e; \
- rm -rf build-gtk3; \
- mkdir build-gtk3; \
- cd build-gtk3; \
- $(DEB_CONFIGURE_SCRIPT_ENV) ../configure --with-gtk=3 \
+ rm -rf build-gtk2; \
+ mkdir build-gtk2; \
+ cd build-gtk2; \
+ $(DEB_CONFIGURE_SCRIPT_ENV) ../configure --with-gtk=2 \
$(filter-out --srcdir=%, $(DEB_CONFIGURE_NORMAL_ARGS) $(DEB_CONFIGURE_EXTRA_FLAGS)) \
--enable-gtk-doc=no; \
cd ..;
- touch stamp-configure-gtk3
+ touch stamp-configure-gtk2
-build/libdbusmenu-gtk3-3:: stamp-build-gtk3
-stamp-build-gtk3: stamp-configure-gtk3
- : # build for GTK+ 3.0
- $(MAKE) -C build-gtk3;
- touch stamp-build-gtk3
+build/libdbusmenu-gtk4:: stamp-build-gtk2
+stamp-build-gtk2: stamp-configure-gtk2
+ : # build for GTK+ 2.0
+ $(MAKE) -C build-gtk2;
+ touch stamp-build-gtk2
-common-install-prehook-arch:: stamp-build-gtk3
- : # install for GTK+ 3.0
- $(MAKE) -C build-gtk3 DESTDIR=$(CURDIR)/debian/tmp install
+common-install-prehook-arch:: stamp-build-gtk2
+ : # install for GTK+ 2.0
+ $(MAKE) -C build-gtk2 DESTDIR=$(CURDIR)/debian/tmp install
binary-predeb/gir%::
dh_girepository -p$(cdbs_curpkg)
clean::
- rm -f stamp-*-gtk3
- rm -rf build-gtk3
+ rm -f stamp-*-gtk2
+ rm -rf build-gtk2