aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-03-03 17:19:47 -0500
committerKen VanDine <ken.vandine@canonical.com>2011-03-03 17:19:47 -0500
commit06885e9d71861edd32d7906ef7ba252f2e064167 (patch)
tree7e8e96a7fe4d23822aa60b6c9ec629a2889ed2d1 /debian
parent86cabf670968df8056246d2f6c3b2c4f6b19399a (diff)
parent2949b7cdafe7c7e4204ca441c14ced5672ddcdd9 (diff)
downloadlibdbusmenu-06885e9d71861edd32d7906ef7ba252f2e064167.tar.gz
libdbusmenu-06885e9d71861edd32d7906ef7ba252f2e064167.tar.bz2
libdbusmenu-06885e9d71861edd32d7906ef7ba252f2e064167.zip
releasing version 0.3.100-0ubuntu1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog22
-rw-r--r--debian/control4
-rw-r--r--debian/patches/bluetooth-applet-fix.patch20
-rw-r--r--debian/patches/disconnect-more-signals.patch18
-rw-r--r--debian/patches/fix-defaults-in-client.patch77
-rw-r--r--debian/patches/lp726678.patch17
-rw-r--r--debian/patches/series4
7 files changed, 24 insertions, 138 deletions
diff --git a/debian/changelog b/debian/changelog
index 3216091..6ae49f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,25 @@
+libdbusmenu (0.3.100-0ubuntu1) natty; urgency=low
+
+ * New upstream release.
+ * GTK application menus are not correctly displayed (LP: #726678)
+ * Fix LP: #723873 - ensure that changing a menuitem property to a
+ default value gets propagated properly in the client
+ * Fix some crashes by disconnecting more signals when a menuitem is
+ deleted. LP: #725980 and LP: #726153
+ * Making sure to grab the variant and dispose of it in handle_event.
+ * Change the destroy prototype to fix GIR warnings
+ * Fix emitting property changes to use tuples
+ * Track the icon theme directories
+ * Handle cases where passed in property names could be in the
+ properties hash table
+ * Making property names match DBus protocol recommendations
+ * Restricting GIR scanner to exported interfaces
+ * Use the library i18n libraries instead of the app ones
+ * Make GetLayout use the parent parameter
+ * debian/patches: All submitted upstream
+
+ -- Ted Gould <ted@ubuntu.com> Thu, 03 Mar 2011 13:54:31 -0600
+
libdbusmenu (0.3.99-0ubuntu5) natty; urgency=low
* debian/patches/lp726678.patch
diff --git a/debian/control b/debian/control
index 6d879d8..a2cd3d3 100644
--- a/debian/control
+++ b/debian/control
@@ -26,8 +26,8 @@ Build-Depends: debhelper (>= 5.0),
valac-0.12
Standards-Version: 3.9.1
Homepage: https://launchpad.net/dbusmenu
-Vcs-Bzr: https://code.launchpad.net/~dbusmenu-team/dbusmenu/ubuntu
-Vcs-Browser: http://bazaar.launchpad.net/~dbusmenu-team/dbusmenu/ubuntu
+Vcs-Bzr: https://code.launchpad.net/~ubuntu-desktop/dbusmenu/ubuntu
+Vcs-Browser: http://bazaar.launchpad.net/~ubuntu-desktop/dbusmenu/ubuntu
Package: libdbusmenu-glib3
Section: libs
diff --git a/debian/patches/bluetooth-applet-fix.patch b/debian/patches/bluetooth-applet-fix.patch
deleted file mode 100644
index 34e0e48..0000000
--- a/debian/patches/bluetooth-applet-fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/libdbusmenu-gtk/parser.c
-+++ b/libdbusmenu-gtk/parser.c
-@@ -456,6 +456,17 @@ construct_dbusmenu_for_widget (GtkWidget
- }
- }
-
-+ GtkWidget *submenu = gtk_menu_item_get_submenu(GTK_MENU_ITEM(widget));
-+ if (submenu)
-+ {
-+ pdata->shell = submenu;
-+ g_signal_connect (G_OBJECT (submenu),
-+ "child-added",
-+ G_CALLBACK (child_added_cb),
-+ mi);
-+ g_object_add_weak_pointer(G_OBJECT(submenu), (gpointer*)&pdata->shell);
-+ }
-+
- if (!g_object_get_data (G_OBJECT (widget), "gtk-empty-menu-item") && !GTK_IS_TEAROFF_MENU_ITEM (widget))
- {
- visible = gtk_widget_get_visible (widget);
diff --git a/debian/patches/disconnect-more-signals.patch b/debian/patches/disconnect-more-signals.patch
deleted file mode 100644
index 653d32c..0000000
--- a/debian/patches/disconnect-more-signals.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-=== modified file 'libdbusmenu-gtk/parser.c'
-Index: libdbusmenu-0.3.99/libdbusmenu-gtk/parser.c
-===================================================================
---- libdbusmenu-0.3.99.orig/libdbusmenu-gtk/parser.c 2011-02-28 10:09:40.907065942 -0500
-+++ libdbusmenu-0.3.99/libdbusmenu-gtk/parser.c 2011-02-28 10:09:43.037065942 -0500
-@@ -129,6 +129,12 @@
- if (pdata != NULL && pdata->widget != NULL) {
- g_signal_handlers_disconnect_matched(pdata->widget, (GSignalMatchType)G_SIGNAL_MATCH_FUNC,
- 0, 0, NULL, G_CALLBACK(widget_notify_cb), NULL);
-+ g_signal_handlers_disconnect_matched(pdata->widget, (GSignalMatchType)G_SIGNAL_MATCH_FUNC,
-+ 0, 0, NULL, G_CALLBACK(accel_changed), NULL);
-+ g_signal_handlers_disconnect_matched(pdata->widget, (GSignalMatchType)G_SIGNAL_MATCH_FUNC,
-+ 0, 0, NULL, G_CALLBACK(checkbox_toggled), NULL);
-+ g_signal_handlers_disconnect_matched(pdata->widget, (GSignalMatchType)G_SIGNAL_MATCH_FUNC,
-+ 0, 0, NULL, G_CALLBACK(menuitem_notify_cb), NULL);
- g_object_remove_weak_pointer(G_OBJECT(pdata->widget), (gpointer*)&pdata->widget);
- }
-
diff --git a/debian/patches/fix-defaults-in-client.patch b/debian/patches/fix-defaults-in-client.patch
deleted file mode 100644
index 8e422db..0000000
--- a/debian/patches/fix-defaults-in-client.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- a/libdbusmenu-glib/menuitem.c
-+++ b/libdbusmenu-glib/menuitem.c
-@@ -1150,9 +1150,9 @@ dbusmenu_menuitem_property_set_variant (
- DbusmenuMenuitemPrivate * priv = DBUSMENU_MENUITEM_GET_PRIVATE(mi);
- GVariant * default_value = NULL;
-
-- if (value != NULL) {
-- const gchar * type = menuitem_get_type(mi);
-+ const gchar * type = menuitem_get_type(mi);
-
-+ if (value != NULL) {
- /* Check the expected type to see if we want to have a warning */
- GVariantType * default_type = dbusmenu_defaults_default_get_type(priv->defaults, type, property);
- if (default_type != NULL) {
-@@ -1163,22 +1163,23 @@ dbusmenu_menuitem_property_set_variant (
- g_warning("Setting menuitem property '%s' with value of type '%s' when expecting '%s'", property, g_variant_get_type_string(value), g_variant_type_peek_string(default_type));
- }
- }
-+ }
-
-- /* Check the defaults database to see if we have a default
-- for this property. */
-- default_value = dbusmenu_defaults_default_get(priv->defaults, type, property);
-- if (default_value != NULL) {
-- /* Now see if we're setting this to the same value as the
-- default. If we are then we just want to swallow this variant
-- and make the function behave like we're clearing it. */
-- if (g_variant_equal(default_value, value)) {
-- g_variant_ref_sink(value);
-- g_variant_unref(value);
-- value = NULL;
-- }
-+ /* Check the defaults database to see if we have a default
-+ for this property. */
-+ default_value = dbusmenu_defaults_default_get(priv->defaults, type, property);
-+ if (default_value != NULL && value != NULL) {
-+ /* Now see if we're setting this to the same value as the
-+ default. If we are then we just want to swallow this variant
-+ and make the function behave like we're clearing it. */
-+ if (g_variant_equal(default_value, value)) {
-+ g_variant_ref_sink(value);
-+ g_variant_unref(value);
-+ value = NULL;
- }
- }
-
-+
- gboolean replaced = FALSE;
- gpointer currentval = g_hash_table_lookup(priv->properties, property);
-
-@@ -1371,9 +1372,7 @@ dbusmenu_menuitem_property_remove (Dbusm
- g_return_if_fail(DBUSMENU_IS_MENUITEM(mi));
- g_return_if_fail(property != NULL);
-
-- DbusmenuMenuitemPrivate * priv = DBUSMENU_MENUITEM_GET_PRIVATE(mi);
--
-- g_hash_table_remove(priv->properties, property);
-+ dbusmenu_menuitem_property_set_variant(mi, property, NULL);
-
- return;
- }
-@@ -1753,13 +1752,8 @@ dbusmenu_menuitem_property_is_default (D
- return FALSE;
- }
-
-- currentval = dbusmenu_defaults_default_get(priv->defaults, menuitem_get_type(mi), property);
-- if (currentval != NULL) {
-- return TRUE;
-- }
--
-- g_warn_if_reached();
-- return FALSE;
-+ /* If we haven't stored it locally, then it's the default */
-+ return TRUE;
- }
-
- /* Check to see if this menu item has been sent into the bus yet or
diff --git a/debian/patches/lp726678.patch b/debian/patches/lp726678.patch
deleted file mode 100644
index e784b60..0000000
--- a/debian/patches/lp726678.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-=== modified file 'libdbusmenu-glib/server.c'
---- a/libdbusmenu-glib/server.c 2011-02-24 19:52:01 +0000
-+++ b/libdbusmenu-glib/server.c 2011-03-01 16:51:50 +0000
-@@ -1180,7 +1180,11 @@
- GVariant * items = NULL;
-
- if (priv->root != NULL) {
-- items = dbusmenu_menuitem_build_variant(priv->root, props, recurse);
-+ DbusmenuMenuitem * mi = dbusmenu_menuitem_find_id(priv->root, parent);
-+
-+ if (mi != NULL) {
-+ items = dbusmenu_menuitem_build_variant(mi, props, recurse);
-+ }
- }
-
- /* What happens if we don't have anything? */
-
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 3467a18..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,4 +0,0 @@
-disconnect-more-signals.patch
-fix-defaults-in-client.patch
-bluetooth-applet-fix.patch
-lp726678.patch