aboutsummaryrefslogtreecommitdiff
path: root/docs/libdbusmenu-glib/reference/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-03-02 16:53:34 -0600
committerTed Gould <ted@gould.cx>2011-03-02 16:53:34 -0600
commitda9a1f784d3c1e8a75f832f60c3f86764810858c (patch)
treee979710140fd56b2a708809cc529459bbaeabfdf /docs/libdbusmenu-glib/reference/Makefile.am
parent08409e83ad0cc9beeb27f3f4dce9b98a43138576 (diff)
parent05298620b764d60b942567d09b970342924099f9 (diff)
downloadlibdbusmenu-da9a1f784d3c1e8a75f832f60c3f86764810858c.tar.gz
libdbusmenu-da9a1f784d3c1e8a75f832f60c3f86764810858c.tar.bz2
libdbusmenu-da9a1f784d3c1e8a75f832f60c3f86764810858c.zip
Sync up to trunk
Diffstat (limited to 'docs/libdbusmenu-glib/reference/Makefile.am')
-rw-r--r--docs/libdbusmenu-glib/reference/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/docs/libdbusmenu-glib/reference/Makefile.am b/docs/libdbusmenu-glib/reference/Makefile.am
index e8a3610..2af5ec3 100644
--- a/docs/libdbusmenu-glib/reference/Makefile.am
+++ b/docs/libdbusmenu-glib/reference/Makefile.am
@@ -48,11 +48,13 @@ CFILE_GLOB=$(top_srcdir)/libdbusmenu-glib/*.c
# Header files to ignore when scanning.
# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
IGNORE_HFILES= \
+ dbus-menu-clean.xml.h \
+ client-menuitem.h \
+ client-private.h \
+ defaults.h \
menuitem-marshal.h \
server-marshal.h \
- menuitem-private.h \
- dbusmenu-client.h \
- dbusmenu-server.h
+ menuitem-private.h
# Images to copy into HTML directory.
# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
@@ -88,5 +90,13 @@ EXTRA_DIST += version.xml.in
#DISTCLEANFILES +=
# Comment this out if you want your docs-status tested during 'make check'
-#TESTS = $(GTKDOC_CHECK)
+TESTS = gtkdoc-in-srcdir
+
+gtkdoc-in-srcdir: Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo "cd \"$(srcdir)\"" >> $@
+ @echo "$(GTKDOC_CHECK)" >> $@
+ @chmod +x $@
+
+DISTCLEANFILES = gtkdoc-in-srcdir