aboutsummaryrefslogtreecommitdiff
path: root/docs/libdbusmenu-glib/reference/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-02-24 15:04:39 -0600
committerTed Gould <ted@gould.cx>2011-02-24 15:04:39 -0600
commitf8fed10917f0f2ebba16d2d6628fad2d2d46c04e (patch)
tree38af9ba8014eff7907c5ae06bcad13f441787abf /docs/libdbusmenu-glib/reference/Makefile.am
parent44927e6da03d633f0958ce5e04e62e752a43d201 (diff)
parentf5ef3600b66047f13796972ee40acf7b50b81790 (diff)
downloadlibdbusmenu-f8fed10917f0f2ebba16d2d6628fad2d2d46c04e.tar.gz
libdbusmenu-f8fed10917f0f2ebba16d2d6628fad2d2d46c04e.tar.bz2
libdbusmenu-f8fed10917f0f2ebba16d2d6628fad2d2d46c04e.zip
Import upstream version 0.3.99
Diffstat (limited to 'docs/libdbusmenu-glib/reference/Makefile.am')
-rw-r--r--docs/libdbusmenu-glib/reference/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/docs/libdbusmenu-glib/reference/Makefile.am b/docs/libdbusmenu-glib/reference/Makefile.am
index e8a3610..2af5ec3 100644
--- a/docs/libdbusmenu-glib/reference/Makefile.am
+++ b/docs/libdbusmenu-glib/reference/Makefile.am
@@ -48,11 +48,13 @@ CFILE_GLOB=$(top_srcdir)/libdbusmenu-glib/*.c
# Header files to ignore when scanning.
# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
IGNORE_HFILES= \
+ dbus-menu-clean.xml.h \
+ client-menuitem.h \
+ client-private.h \
+ defaults.h \
menuitem-marshal.h \
server-marshal.h \
- menuitem-private.h \
- dbusmenu-client.h \
- dbusmenu-server.h
+ menuitem-private.h
# Images to copy into HTML directory.
# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
@@ -88,5 +90,13 @@ EXTRA_DIST += version.xml.in
#DISTCLEANFILES +=
# Comment this out if you want your docs-status tested during 'make check'
-#TESTS = $(GTKDOC_CHECK)
+TESTS = gtkdoc-in-srcdir
+
+gtkdoc-in-srcdir: Makefile.am
+ @echo "#!/bin/sh" > $@
+ @echo "cd \"$(srcdir)\"" >> $@
+ @echo "$(GTKDOC_CHECK)" >> $@
+ @chmod +x $@
+
+DISTCLEANFILES = gtkdoc-in-srcdir