aboutsummaryrefslogtreecommitdiff
path: root/libdbusmenu-glib/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-14 10:36:48 -0600
committerTed Gould <ted@gould.cx>2011-01-14 10:36:48 -0600
commit2461e539704dc3b306c24b5b841be342111a76b9 (patch)
tree36293d9dbbf964f7f1fe54765140c19564c861b1 /libdbusmenu-glib/Makefile.am
parentb76ed9c7f918123610e5e56bb9cdd1025d34caa1 (diff)
parentece305e4b1b4eee4e3fb54faf8f9c291ef915e8c (diff)
downloadlibdbusmenu-2461e539704dc3b306c24b5b841be342111a76b9.tar.gz
libdbusmenu-2461e539704dc3b306c24b5b841be342111a76b9.tar.bz2
libdbusmenu-2461e539704dc3b306c24b5b841be342111a76b9.zip
Import upstream version 0.3.92
Diffstat (limited to 'libdbusmenu-glib/Makefile.am')
-rw-r--r--libdbusmenu-glib/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libdbusmenu-glib/Makefile.am b/libdbusmenu-glib/Makefile.am
index 4a65ac0..a1247a3 100644
--- a/libdbusmenu-glib/Makefile.am
+++ b/libdbusmenu-glib/Makefile.am
@@ -56,10 +56,10 @@ pkgconfig_DATA = dbusmenu-glib-0.4.pc
pkgconfigdir = $(libdir)/pkgconfig
%.xml.h: %.xml
- echo "extern const char * $(subst -,_,$(subst .,_,$(basename $@)));" > $@
+ echo "extern const char * $(subst -,_,$(subst .,_,$(basename $(notdir $@))));" > $@
%.xml.c: %.xml
- echo "const char * $(subst -,_,$(subst .,_,$(basename $@))) = " > $@
+ echo "const char * $(subst -,_,$(subst .,_,$(basename $(notdir $@)))) = " > $@
sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
echo ";" >> $@