aboutsummaryrefslogtreecommitdiff
path: root/libdbusmenu-glib/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-26 13:45:00 -0600
committerTed Gould <ted@gould.cx>2012-01-26 13:45:00 -0600
commit310990fdddef125e167e6ea28ab84d25110005b2 (patch)
tree231b068d1d4199dd5ade54da8ff35855eedd4aa9 /libdbusmenu-glib/Makefile.am
parent759261cdb327bb0fb06bae3ac99d2d0717f5a2f4 (diff)
parent4eae3efbe5c3aa84035b2ade9ceedd68b7b3e895 (diff)
downloadlibdbusmenu-310990fdddef125e167e6ea28ab84d25110005b2.tar.gz
libdbusmenu-310990fdddef125e167e6ea28ab84d25110005b2.tar.bz2
libdbusmenu-310990fdddef125e167e6ea28ab84d25110005b2.zip
Change to using the insert/remove signals in GTK3
Diffstat (limited to 'libdbusmenu-glib/Makefile.am')
-rw-r--r--libdbusmenu-glib/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libdbusmenu-glib/Makefile.am b/libdbusmenu-glib/Makefile.am
index 71dce6d..6fc3fb8 100644
--- a/libdbusmenu-glib/Makefile.am
+++ b/libdbusmenu-glib/Makefile.am
@@ -62,7 +62,9 @@ libdbusmenu_glib_la_LDFLAGS = \
-export-symbols-regex "^[^_].*"
libdbusmenu_glib_la_CFLAGS = \
- $(DBUSMENUGLIB_CFLAGS) -Wall -Werror -DG_DISABLE_DEPRECATED -DG_LOG_DOMAIN="\"LIBDBUSMENU-GLIB\""
+ $(DBUSMENUGLIB_CFLAGS) \
+ -Wall -Werror -Wno-error=deprecated-declarations \
+ -DG_LOG_DOMAIN="\"LIBDBUSMENU-GLIB\""
libdbusmenu_glib_la_LIBADD = \
$(DBUSMENUGLIB_LIBS)