aboutsummaryrefslogtreecommitdiff
path: root/libdbusmenu-glib/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-05-12 15:35:28 -0500
committerTed Gould <ted@canonical.com>2009-05-12 15:35:28 -0500
commit6e8815b08af88622cd5add61a7088fc45ab73f37 (patch)
tree2ffa3f7588bf254f938b2f67399f6188ab367e57 /libdbusmenu-glib/Makefile.am
parent777fdb298f9f61e309fa9d0c31adb015667f9358 (diff)
downloadlibdbusmenu-6e8815b08af88622cd5add61a7088fc45ab73f37.tar.gz
libdbusmenu-6e8815b08af88622cd5add61a7088fc45ab73f37.tar.bz2
libdbusmenu-6e8815b08af88622cd5add61a7088fc45ab73f37.zip
Getting the proper marshaller for the change in API
Diffstat (limited to 'libdbusmenu-glib/Makefile.am')
-rw-r--r--libdbusmenu-glib/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/libdbusmenu-glib/Makefile.am b/libdbusmenu-glib/Makefile.am
index b273555..844e1b8 100644
--- a/libdbusmenu-glib/Makefile.am
+++ b/libdbusmenu-glib/Makefile.am
@@ -1,7 +1,9 @@
EXTRA_DIST = \
dbusmenu-glib.pc.in \
- dbus-menu.xml
+ dbus-menu.xml \
+ menuitem-marshal.list \
+ server-marshal.list
lib_LTLIBRARIES = \
libdbusmenu-glib.la
@@ -18,6 +20,8 @@ libdbusmenu_glib_la_SOURCES = \
dbusmenu-client.h \
menuitem.h \
menuitem.c \
+ menuitem-marshal.h \
+ menuitem-marshal.c \
server.h \
server.c \
server-marshal.h \
@@ -42,6 +46,8 @@ pkgconfigdir = $(libdir)/pkgconfig
BUILT_SOURCES = \
dbusmenu-client.h \
dbusmenu-server.h \
+ menuitem-marshal.h \
+ menuitem-marshal.c \
server-marshal.h \
server-marshal.c
@@ -69,3 +75,13 @@ server-marshal.c: $(srcdir)/server-marshal.list
--prefix=_dbusmenu_server_marshal $(srcdir)/server-marshal.list \
> server-marshal.c
+menuitem-marshal.h: $(srcdir)/menuitem-marshal.list
+ glib-genmarshal --header \
+ --prefix=_dbusmenu_menuitem_marshal $(srcdir)/menuitem-marshal.list \
+ > menuitem-marshal.h
+
+menuitem-marshal.c: $(srcdir)/menuitem-marshal.list
+ glib-genmarshal --body \
+ --prefix=_dbusmenu_menuitem_marshal $(srcdir)/menuitem-marshal.list \
+ > menuitem-marshal.c
+