aboutsummaryrefslogtreecommitdiff
path: root/libdbusmenu-gtk/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-01-26 13:36:57 -0600
committerTed Gould <ted@gould.cx>2012-01-26 13:36:57 -0600
commit4eae3efbe5c3aa84035b2ade9ceedd68b7b3e895 (patch)
tree12e30622f365a6901573a2a79c475f1f28ab5d99 /libdbusmenu-gtk/Makefile.am
parentd0065933d25307a95644e3ab984de0f4f848d6ad (diff)
downloadlibdbusmenu-4eae3efbe5c3aa84035b2ade9ceedd68b7b3e895.tar.gz
libdbusmenu-4eae3efbe5c3aa84035b2ade9ceedd68b7b3e895.tar.bz2
libdbusmenu-4eae3efbe5c3aa84035b2ade9ceedd68b7b3e895.zip
Move the no-error on deprications into the Makefiles so it's always after the -Wall
Diffstat (limited to 'libdbusmenu-gtk/Makefile.am')
-rw-r--r--libdbusmenu-gtk/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/libdbusmenu-gtk/Makefile.am b/libdbusmenu-gtk/Makefile.am
index b4564d1..9f297f5 100644
--- a/libdbusmenu-gtk/Makefile.am
+++ b/libdbusmenu-gtk/Makefile.am
@@ -62,7 +62,10 @@ libdbusmenu_gtk_la_LDFLAGS = \
-export-symbols-regex "^[^_].*"
libdbusmenu_gtk_la_CFLAGS = \
- $(DBUSMENUGTK_CFLAGS) -I$(top_srcdir) -Wall -Werror -DG_DISABLE_DEPRECATED -DG_LOG_DOMAIN="\"LIBDBUSMENU-GTK\""
+ $(DBUSMENUGTK_CFLAGS) \
+ -I$(top_srcdir) \
+ -Wall -Werror -Wno-error=deprecated-declarations \
+ -DG_LOG_DOMAIN="\"LIBDBUSMENU-GTK\""
libdbusmenu_gtk_la_LIBADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \