aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-04-03 09:55:04 -0500
committerTed Gould <ted@gould.cx>2012-04-03 09:55:04 -0500
commit0afc1bc524816f08bcd459c96654ffc1dc6ddbb4 (patch)
treefa869ca2547038cfbf6d02ade3bfe00100530abc /tests/Makefile.am
parent5962851c31527fdb43a3d3b9b2c98ebeaaee88e8 (diff)
downloadlibdbusmenu-0afc1bc524816f08bcd459c96654ffc1dc6ddbb4.tar.gz
libdbusmenu-0afc1bc524816f08bcd459c96654ffc1dc6ddbb4.tar.bz2
libdbusmenu-0afc1bc524816f08bcd459c96654ffc1dc6ddbb4.zip
Adding a test that disables the event grouping
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 82f6a9d..7ff2bb4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,6 +8,7 @@ EXTRA_DIST =
TESTS = \
test-glib-objects-test \
test-glib-events \
+ test-glib-events-nogroup \
test-glib-layout \
test-glib-properties \
test-glib-proxy \
@@ -45,6 +46,7 @@ check_PROGRAMS = \
test-glib-objects \
test-glib-events-client \
test-glib-events-server \
+ test-glib-events-nogroup-client \
test-glib-layout-client \
test-glib-layout-server \
test-glib-properties-client \
@@ -200,6 +202,28 @@ test_glib_events_client_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+################################
+# Test Glib Events No Grouping
+################################
+
+test-glib-events-nogroup: test-glib-events-nogroup-client test-glib-events-server Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo export UBUNTU_MENUPROXY="" >> $@
+ @echo export G_DEBUG=fatal_criticals >> $@
+ @echo $(DBUS_RUNNER) --task ./test-glib-events-nogroup-client --task-name Client --task ./test-glib-events-server --task-name Server --ignore-return >> $@
+ @chmod +x $@
+
+test_glib_events_nogroup_client_SOURCES = \
+ test-glib-events-nogroup-client.c
+
+test_glib_events_nogroup_client_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_glib_events_nogroup_client_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS)
+
######################
# Test JSON
######################