aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-09-20 08:52:46 -0700
committerKen VanDine <ken.vandine@canonical.com>2011-09-20 08:52:46 -0700
commit19c94937db3760924a02a4bda4e122a5919d12c2 (patch)
tree00cefd028c54e349afec0593e158bb94512ad038 /tests/Makefile.am
parent78dac37f516e78b8677b48484961f56035a5a8bb (diff)
parent70c33b0c4c7ce124ac203020f2f3b0a392727577 (diff)
downloadlibdbusmenu-19c94937db3760924a02a4bda4e122a5919d12c2.tar.gz
libdbusmenu-19c94937db3760924a02a4bda4e122a5919d12c2.tar.bz2
libdbusmenu-19c94937db3760924a02a4bda4e122a5919d12c2.zip
New upstream release.
∘ Protect functions from NULL submenus (LP: #803667) ∘ Build fixes (LP: #552526, LP: #552530, LP: #552538, LP: #709761, LP: #713690, LP: #643871, LP: #713685)
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am28
1 files changed, 22 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a4763da..a4e8682 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,14 +12,22 @@ TESTS = \
test-glib-properties \
test-glib-proxy \
test-glib-simple-items \
- test-glib-submenu \
- test-json \
+ test-glib-submenu
+
+if WANT_DBUSMENUDUMPER
+TESTS += \
+ test-json
+endif
+
+if WANT_LIBDBUSMENUGTK
+TESTS += \
test-gtk-objects-test \
test-gtk-label \
test-gtk-shortcut \
test-gtk-reorder \
test-gtk-submenu \
test-gtk-parser-test
+endif
XFAIL_TESTS = \
test-glib-proxy
@@ -44,20 +52,28 @@ check_PROGRAMS = \
test-glib-proxy-client \
test-glib-proxy-server \
test-glib-proxy-proxy \
- test-gtk-objects \
test-glib-submenu-client \
test-glib-submenu-server \
+ test-glib-simple-items
+
+if WANT_DBUSMENUDUMPER
+check_PROGRAMS += \
+ test-json-client \
+ test-json-server
+endif
+
+if WANT_LIBDBUSMENUGTK
+check_PROGRAMS += \
+ test-gtk-objects \
test-gtk-label-client \
test-gtk-label-server \
test-gtk-shortcut-client \
test-gtk-shortcut-server \
- test-glib-simple-items \
test-gtk-reorder-server \
- test-json-client \
- test-json-server \
test-gtk-submenu-server \
test-gtk-submenu-client \
test-gtk-parser
+endif
XVFB_RUN=". $(srcdir)/run-xvfb.sh"