aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-06-17 13:48:50 -0500
committerTed Gould <ted@canonical.com>2009-06-17 13:48:50 -0500
commit23b418faf95a4e8fef6c98726309292325b5919c (patch)
tree27e40bd39f677e48492a1a9694399fb51877d195 /tests/Makefile.am
parent757ec5c8852ca964f25326e96c66c0e44c8614b8 (diff)
downloadlibdbusmenu-23b418faf95a4e8fef6c98726309292325b5919c.tar.gz
libdbusmenu-23b418faf95a4e8fef6c98726309292325b5919c.tar.bz2
libdbusmenu-23b418faf95a4e8fef6c98726309292325b5919c.zip
Adding in json-glib to make the tests more configurable.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 70750ac..3e818a2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -94,12 +94,14 @@ test_gtk_label_server_SOURCES = \
test_gtk_label_server_CFLAGS = \
-I $(srcdir)/.. \
$(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUTESTS_CFLAGS) \
$(DBUSMENUGLIB_CFLAGS) -Wall -Werror
test_gtk_label_server_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
../libdbusmenu-gtk/libdbusmenu-gtk.la \
- $(DBUSMENUGTK_LIBS)
+ $(DBUSMENUGTK_LIBS) \
+ $(DBUSMENUTESTS_LIBS)
test_gtk_label_client_SOURCES = \
test-gtk-label.h \
@@ -108,12 +110,14 @@ test_gtk_label_client_SOURCES = \
test_gtk_label_client_CFLAGS = \
-I $(srcdir)/.. \
$(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUTESTS_CFLAGS) \
$(DBUSMENUGLIB_CFLAGS) -Wall -Werror
test_gtk_label_client_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
../libdbusmenu-gtk/libdbusmenu-gtk.la \
- $(DBUSMENUGTK_LIBS)
+ $(DBUSMENUGTK_LIBS) \
+ $(DBUSMENUTESTS_LIBS)