aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDennis Schridde <devurandom@gmx.net>2011-09-19 23:43:26 -0500
committerTed Gould <ted@gould.cx>2011-09-19 23:43:26 -0500
commit4177700e45a02a7f35b32dc24dd7ec6e150d6a0a (patch)
tree08fe1f670ad1f93459773f61e3c0251a4d9116cc /tests/Makefile.am
parent21afbd946557e93304bdb34199d62594f365799f (diff)
downloadlibdbusmenu-4177700e45a02a7f35b32dc24dd7ec6e150d6a0a.tar.gz
libdbusmenu-4177700e45a02a7f35b32dc24dd7ec6e150d6a0a.tar.bz2
libdbusmenu-4177700e45a02a7f35b32dc24dd7ec6e150d6a0a.zip
Adding an optional build of the dumper
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e6882af..a4e8682 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -12,8 +12,12 @@ TESTS = \
test-glib-properties \
test-glib-proxy \
test-glib-simple-items \
- test-glib-submenu \
+ test-glib-submenu
+
+if WANT_DBUSMENUDUMPER
+TESTS += \
test-json
+endif
if WANT_LIBDBUSMENUGTK
TESTS += \
@@ -50,9 +54,13 @@ check_PROGRAMS = \
test-glib-proxy-proxy \
test-glib-submenu-client \
test-glib-submenu-server \
- test-glib-simple-items \
+ test-glib-simple-items
+
+if WANT_DBUSMENUDUMPER
+check_PROGRAMS += \
test-json-client \
test-json-server
+endif
if WANT_LIBDBUSMENUGTK
check_PROGRAMS += \