aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-21 14:56:49 -0600
committerTed Gould <ted@gould.cx>2009-12-21 14:56:49 -0600
commit46532dd8beb62a6aa4a639ee646eb0bf1682b75c (patch)
tree5c61fbdc77f15f5366a1dd019a8eaec671db9710 /tests/Makefile.am
parentb03128c902c0b9906a34e3cc9f4fc5985d7a06d3 (diff)
downloadlibdbusmenu-46532dd8beb62a6aa4a639ee646eb0bf1682b75c.tar.gz
libdbusmenu-46532dd8beb62a6aa4a639ee646eb0bf1682b75c.tar.bz2
libdbusmenu-46532dd8beb62a6aa4a639ee646eb0bf1682b75c.zip
Adding in an XML report file.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0c2ab57..fa18b9d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -76,9 +76,11 @@ test_glib_layout_client_LDADD = \
# Test Glib Object
######################
+OBJECT_XML_REPORT = test-glib-objects.xml
+
test-glib-objects-test: test-glib-objects Makefile.am
@echo "#!/bin/bash" > $@
- @echo $(DBUS_RUNNER) -b $@.bustle --task gtester --parameter ./test-glib-objects >> $@
+ @echo $(DBUS_RUNNER) -b $@.bustle --task gtester --parameter -k --parameter -o --parameter $(OBJECT_XML_REPORT) --parameter ./test-glib-objects >> $@
@chmod +x $@
test_glib_objects_SOURCES = \
@@ -261,6 +263,7 @@ distclean-local:
DISTCLEANFILES = \
$(TESTS) \
+ $(OBJECT_XML_FILE) \
test-glib-objects-test.bustle \
test-glib-layout.bustle \
test-glib-properties.bustle \