aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEvgeni Golov <evgeni@debian.org>2010-07-01 11:24:43 +0200
committerEvgeni Golov <evgeni@debian.org>2010-07-01 11:24:43 +0200
commit6830905830ac78271515c586442a090cf7a0e3ff (patch)
tree9f5ef29e46f14d553df2622d38df80ea6ee1f0ac /tests/Makefile.am
parentc6d95ac4d53118c0a2f4b05c760bd03cc55e8c67 (diff)
parent01780416e8c1267838892fb6d114a84fe33dc590 (diff)
downloadlibdbusmenu-6830905830ac78271515c586442a090cf7a0e3ff.tar.gz
libdbusmenu-6830905830ac78271515c586442a090cf7a0e3ff.tar.bz2
libdbusmenu-6830905830ac78271515c586442a090cf7a0e3ff.zip
Merging lp:~ubuntu-desktop/dbusmenu/ubuntu
* New upstream release. * Adding support for menu shortcuts (LP: #591293) * Fixing distcheck of documentation builds * Autogen.sh fix for adding custom prefix (LP: #595565) * Fixing children property name to match spec (LP: #597321) * Merging in Debian branch * debian/control: Switching branch on this branch to be the dbusmenu-team. * debian/rules: Updating shlibs to 0.3.3 for shortcut API additions * Merge from Ubuntu. Closes: #586069 * debian/control: - Set Maintainer to pkg-ayatana. - Add myself as Uploader. - Update package descriptions. - Standards-Version: 3.8.4 - Fix Homepage URL. - Update Vcs-* fields. * debian/copyright: - Convert to DEP5 format. - Add Ken and Sebastien, according to changelog. - Add Aurélien Gâteau, according to headers.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am79
1 files changed, 77 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f1b50bc..66f286b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -7,8 +7,10 @@ TESTS = \
test-glib-properties \
test-glib-proxy \
test-glib-simple-items \
+ test-gtk-objects-test \
test-glib-submenu \
test-gtk-label \
+ test-gtk-shortcut \
test-gtk-reorder
check_PROGRAMS = \
@@ -21,10 +23,13 @@ check_PROGRAMS = \
test-glib-proxy-client \
test-glib-proxy-server \
test-glib-proxy-proxy \
+ test-gtk-objects \
test-glib-submenu-client \
test-glib-submenu-server \
test-gtk-label-client \
test-gtk-label-server \
+ test-gtk-shortcut-client \
+ test-gtk-shortcut-server \
test-glib-simple-items \
test-gtk-reorder-server
@@ -119,7 +124,7 @@ OBJECT_XML_REPORT = test-glib-objects.xml
test-glib-objects-test: test-glib-objects Makefile.am
@echo "#!/bin/bash" > $@
- @echo $(DBUS_RUNNER) --task gtester --parameter --verbose --parameter -k --parameter -o --parameter $(OBJECT_XML_REPORT) --parameter ./test-glib-objects >> $@
+ @echo $(DBUS_RUNNER) --task gtester --task-name test --parameter --verbose --parameter -k --parameter -o --parameter $(OBJECT_XML_REPORT) --parameter ./test-glib-objects >> $@
@chmod +x $@
test_glib_objects_SOURCES = \
@@ -231,6 +236,34 @@ test_glib_simple_items_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+######################
+# Test GTK Object
+######################
+
+GTK_OBJECT_XML_REPORT = test-gtk-objects.xml
+
+test-gtk-objects-test: test-gtk-objects Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo $(DBUS_RUNNER) --task gtester --task-name test --parameter --verbose --parameter -k --parameter -o --parameter $(GTK_OBJECT_XML_REPORT) --parameter ./test-gtk-objects >> $@
+ @chmod +x $@
+
+test_gtk_objects_SOURCES = \
+ test-gtk-objects.c
+
+test_gtk_objects_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) \
+ $(DBUSMENUGTK_CFLAGS) \
+ -DSRCDIR="\"$(srcdir)\"" \
+ -Wall -Werror
+
+test_gtk_objects_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGLIB_LIBS) \
+ $(DBUSMENUGTK_LIBS)
+
#########################
# Test GTK Label
#########################
@@ -272,6 +305,46 @@ test_gtk_label_client_LDADD = \
$(DBUSMENUTESTS_LIBS)
#########################
+# Test GTK Shortcut
+#########################
+
+test-gtk-shortcut: test-gtk-shortcut-client test-gtk-shortcut-server Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
+ @chmod +x $@
+
+test_gtk_shortcut_server_SOURCES = \
+ test-gtk-shortcut-server.c
+
+test_gtk_shortcut_server_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUTESTS_CFLAGS) \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_gtk_shortcut_server_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGTK_LIBS) \
+ $(DBUSMENUTESTS_LIBS)
+
+test_gtk_shortcut_client_SOURCES = \
+ test-gtk-shortcut-client.c
+
+test_gtk_shortcut_client_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUTESTS_CFLAGS) \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_gtk_shortcut_client_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGTK_LIBS) \
+ $(DBUSMENUTESTS_LIBS)
+
+#########################
# Test GTK Reorder
#########################
@@ -329,6 +402,7 @@ EXTRA_DIST = \
$(examples_DATA) \
run-xvfb.sh \
$(json_DATA) \
+ test-gtk-objects.jpg \
dbusmenu-gtk/dbusMenuTest \
dbusmenu-gtk/mago_tests/dbusmenu.xml \
dbusmenu-gtk/mago_tests/dbusmenu.py \
@@ -357,5 +431,6 @@ distclean-local:
DISTCLEANFILES = \
$(TESTS) \
- $(OBJECT_XML_REPORT)
+ $(OBJECT_XML_REPORT) \
+ $(GTK_OBJECT_XML_REPORT)