aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorIain Lane <iain@orangesquash.org.uk>2015-04-09 17:35:57 +0000
committerCI Train Bot <ci-train-bot@canonical.com>2015-04-09 17:35:57 +0000
commit719a40ec821dfbc2ec2f03fd1d1b0057d6e8dee8 (patch)
tree3f88f07b08d5d0dc04dae53e6126b54bf3b110dc /tests/Makefile.am
parent3645d9efd849c56a1bece51d00b6aa76ff7bdda3 (diff)
parent0f5a3df06500837b8251b99fed0c6d17b826576f (diff)
downloadlibdbusmenu-719a40ec821dfbc2ec2f03fd1d1b0057d6e8dee8.tar.gz
libdbusmenu-719a40ec821dfbc2ec2f03fd1d1b0057d6e8dee8.tar.bz2
libdbusmenu-719a40ec821dfbc2ec2f03fd1d1b0057d6e8dee8.zip
Use the configure-generated libtool script instead of /usr/bin/libtool, which might not match what we have. Also use gi's typelibdir pkgconfig variable and install into this directory, now that gi supports multiarch.
Approved by: Ted Gould
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 716d773..06191b1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -249,7 +249,7 @@ test-json-instruction: test-json-client test-json-server test-json-instruction-c
@echo export G_DEBUG=fatal_criticals >> $@
@echo export G_MESSAGES_DEBUG=all >> $@
@echo $(XVFB_RUN) >> $@
- @echo $(DBUS_RUNNER) --task $(builddir)/test-json-client --wait-for org.dbusmenu.test --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter /dev/null --task libtool --parameter --mode=execute --parameter $(srcdir)/test-json-instruction-count --parameter $(builddir)/test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json >> $@
+ @echo $(DBUS_RUNNER) --task $(builddir)/test-json-client --wait-for org.dbusmenu.test --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter /dev/null --task "$(abs_top_builddir)/libtool" --parameter --mode=execute --parameter $(srcdir)/test-json-instruction-count --parameter $(builddir)/test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json >> $@
@chmod +x $@
EXTRA_DIST += \