aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-08-27 14:31:44 -0500
committerTed Gould <ted@gould.cx>2010-08-27 14:31:44 -0500
commit8a2340c7249a714bf5c7128082b8c0c26f20a05f (patch)
treecadbef0849243ce01a571a25f29cf6c39926922a /tests/Makefile.am
parent34824cf6f98cd623b0368e4dbc9eaf65110572d1 (diff)
downloadlibdbusmenu-8a2340c7249a714bf5c7128082b8c0c26f20a05f.tar.gz
libdbusmenu-8a2340c7249a714bf5c7128082b8c0c26f20a05f.tar.bz2
libdbusmenu-8a2340c7249a714bf5c7128082b8c0c26f20a05f.zip
Adding in an events test
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9f621cb..aa79c8f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -5,6 +5,7 @@ CLEANFILES=
TESTS = \
test-glib-objects-test \
+ test-glib-events \
test-glib-layout \
test-glib-properties \
test-glib-proxy \
@@ -20,6 +21,8 @@ TESTS = \
check_PROGRAMS = \
glib-server-nomenu \
test-glib-objects \
+ test-glib-events-client \
+ test-glib-events-server \
test-glib-layout-client \
test-glib-layout-server \
test-glib-properties-client \
@@ -129,6 +132,37 @@ test_glib_layout_client_LDADD = \
$(DBUSMENUGLIB_LIBS)
######################
+# Test Glib Events
+######################
+
+test-glib-events: test-glib-events-client test-glib-events-server Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(DBUS_RUNNER) --task ./test-glib-events-client --task-name Client --task ./test-glib-events-server --task-name Server --ignore-return >> $@
+ @chmod +x $@
+
+test_glib_events_server_SOURCES = \
+ test-glib-events-server.c
+
+test_glib_events_server_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_glib_events_server_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS)
+
+test_glib_events_client_SOURCES = \
+ test-glib-events-client.c
+
+test_glib_events_client_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_glib_events_client_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS)
+
+######################
# Test JSON
######################