aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-28 22:02:53 -0500
committerTed Gould <ted@gould.cx>2010-06-28 22:02:53 -0500
commit8bfa911170eecf8b7c4dda05238777e1c066670f (patch)
tree82e9b0392833170186c941338194a63b82799915 /tests/Makefile.am
parent89f7fb74fba3d5a42603af450f4642fe43ac0406 (diff)
downloadlibdbusmenu-8bfa911170eecf8b7c4dda05238777e1c066670f.tar.gz
libdbusmenu-8bfa911170eecf8b7c4dda05238777e1c066670f.tar.bz2
libdbusmenu-8bfa911170eecf8b7c4dda05238777e1c066670f.zip
Comparing at the end and running under Xvfb
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1f7e36e..31a8910 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -127,7 +127,9 @@ test_glib_layout_client_LDADD = \
test-json: test-json-client test-json-server Makefile.am
@echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
@echo $(DBUS_RUNNER) --task ./test-json-client --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter output.json --ignore-return --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json --ignore-return >> $@
+ @echo diff test-json-01.json output.json \> /dev/null >> $@
@chmod +x $@
test_json_server_SOURCES = \