aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-02-18 12:54:09 -0600
committerTed Gould <ted@gould.cx>2011-02-18 12:54:09 -0600
commit92029bc783017bec46a862ae79d72076157ac38f (patch)
tree5cd21774ca4416d4858bea14b659eb4f4d8d9d5d /tests/Makefile.am
parentbcedc26848a0fe4f2f67a129d34976f69eb03fdf (diff)
parent87703b408d42ce97b5a64142b0c33951d366890a (diff)
downloadlibdbusmenu-92029bc783017bec46a862ae79d72076157ac38f.tar.gz
libdbusmenu-92029bc783017bec46a862ae79d72076157ac38f.tar.bz2
libdbusmenu-92029bc783017bec46a862ae79d72076157ac38f.zip
Updating to trunk
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 62142dc..32c8437 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@
DBUS_RUNNER=dbus-test-runner
CLEANFILES=
+DISTCLEANFILES=
TESTS = \
test-glib-objects-test \
@@ -260,6 +261,8 @@ test_glib_objects_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+DISTCLEANFILES += $(OBJECT_XML_REPORT)
+
######################
# Test Glib Properties
######################
@@ -386,6 +389,8 @@ test_gtk_objects_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+DISTCLEANFILES += $(GTK_OBJECT_XML_REPORT)
+
######################
# Test GTK Parser
######################
@@ -414,6 +419,7 @@ test_gtk_parser_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+DISTCLEANFILES += $(GTK_PARSER_XML_REPORT)
#########################
# Test GTK Label
@@ -622,8 +628,6 @@ CLEANFILES += \
distclean-local:
-rm -rf $(builddir)/mago.results
-DISTCLEANFILES = \
- $(TESTS) \
- $(OBJECT_XML_REPORT) \
- $(GTK_OBJECT_XML_REPORT)
+DISTCLEANFILES += \
+ $(TESTS)