aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-03-13 17:16:48 +0000
committerCharles Kerr <charles.kerr@canonical.com>2013-03-13 17:16:48 +0000
commit9b75358ca14e1ad8a41c364195df748a1a1bbf5d (patch)
treebaf1e3f7051216f46da49a8a1d82dde3d4ca20e9 /tests/Makefile.am
parent7453a4ef0ecd0e44b8296899f3021587e8110f4e (diff)
downloadlibdbusmenu-9b75358ca14e1ad8a41c364195df748a1a1bbf5d.tar.gz
libdbusmenu-9b75358ca14e1ad8a41c364195df748a1a1bbf5d.tar.bz2
libdbusmenu-9b75358ca14e1ad8a41c364195df748a1a1bbf5d.zip
stop listening to a widget's signals when it's removed from the menu tree that we're mirroring. This condition was detected by a flood of g_warnings, so add a regression test to confirm that the warning messages no longer appear.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0cd68d0..356d803 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -29,6 +29,7 @@ TESTS += \
test-gtk-label \
test-gtk-shortcut \
test-gtk-reorder \
+ test-gtk-remove \
test-gtk-parser-test
# Not working with GTK3 and a critical grab that is in
# the GTK3 code.
@@ -71,6 +72,7 @@ endif
if WANT_LIBDBUSMENUGTK
check_PROGRAMS += \
test-gtk-objects \
+ test-gtk-remove \
test-gtk-label-client \
test-gtk-label-server \
test-gtk-shortcut-client \
@@ -621,6 +623,25 @@ EXTRA_DIST += test-gtk-shortcut-client.py
CLEANFILES += test-gtk-shortcut-client.pyc
#########################
+# Test GTK Remove
+#########################
+
+test_gtk_remove_SOURCES = \
+ test-gtk-remove.c
+
+test_gtk_remove_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUTESTS_CFLAGS) \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_gtk_remove_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
+ $(DBUSMENUGTK_LIBS) \
+ $(DBUSMENUTESTS_LIBS)
+
+#########################
# Test GTK Reorder
#########################