aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2009-12-09 15:32:43 -0600
committerTed Gould <ted@gould.cx>2009-12-09 15:32:43 -0600
commita3492a08d1d914f0d62f8cc717288d4c10cda3ef (patch)
tree2d7c094f9b5acfb586c167c4391426748ed16183 /tests/Makefile.am
parentcf65a3c712a12a85ac1a624e493acfb61b967479 (diff)
downloadlibdbusmenu-a3492a08d1d914f0d62f8cc717288d4c10cda3ef.tar.gz
libdbusmenu-a3492a08d1d914f0d62f8cc717288d4c10cda3ef.tar.bz2
libdbusmenu-a3492a08d1d914f0d62f8cc717288d4c10cda3ef.zip
Adding in a bunch of bustle data gathering and cleanup.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 36b870d..1d58700 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,5 @@
-DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+DBUS_RUNNER=dbus-test-runner
TESTS = \
test-glib-layout \
@@ -42,7 +42,7 @@ glib_server_nomenu_LDADD = \
test-glib-layout: test-glib-layout-client test-glib-layout-server Makefile.am
@echo "#!/bin/bash" > $@
- @echo $(DBUS_RUNNER) -b test-glib-layout.bustle --task ./test-glib-layout-client --task-name Client --task ./test-glib-layout-server --task-name Server --ignore-return >> $@
+ @echo $(DBUS_RUNNER) -b $@.bustle --task ./test-glib-layout-client --task-name Client --task ./test-glib-layout-server --task-name Server --ignore-return >> $@
@chmod +x $@
test_glib_layout_server_SOURCES = \
@@ -76,7 +76,7 @@ test_glib_layout_client_LDADD = \
test-glib-properties: test-glib-properties-client test-glib-properties-server Makefile.am
@echo "#!/bin/bash" > $@
- @echo $(DBUS_RUNNER) --task ./test-glib-properties-client --task-name Client --task ./test-glib-properties-server --task-name Server --ignore-return >> $@
+ @echo $(DBUS_RUNNER) -b $@.bustle --task ./test-glib-properties-client --task-name Client --task ./test-glib-properties-server --task-name Server --ignore-return >> $@
@chmod +x $@
test_glib_properties_server_SOURCES = \
@@ -125,7 +125,7 @@ test_glib_simple_items_LDADD = \
test-gtk-label: test-gtk-label-client test-gtk-label-server test-gtk-label.json Makefile.am
@echo "#!/bin/bash" > $@
@echo $(XVFB_RUN) >> $@
- @echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
+ @echo $(DBUS_RUNNER) -b $@.bustle --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
@chmod +x $@
test_gtk_label_server_SOURCES = \
@@ -165,7 +165,7 @@ test_gtk_label_client_LDADD = \
test-gtk-reorder: test-gtk-label-client test-gtk-reorder-server Makefile.am
@echo "#!/bin/bash" > $@
@echo $(XVFB_RUN) >> $@
- @echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-reorder-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
+ @echo $(DBUS_RUNNER) -b $@.bustle --task ./test-gtk-label-client --task-name Client --task ./test-gtk-reorder-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> $@
@chmod +x $@
test_gtk_reorder_server_SOURCES = \
@@ -239,4 +239,8 @@ distclean-local:
DISTCLEANFILES = \
$(TESTS) \
- test-glib-layout.bustle
+ test-glib-layout.bustle \
+ test-glib-properties.bustle \
+ test-glib-simple-items.bustle \
+ test-gtk-label.bustle \
+ test-gtk-reorder.bustle