aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2010-06-14 13:10:18 -0500
committerTed Gould <ted@gould.cx>2010-06-14 13:10:18 -0500
commitb29f86be192fda821b7245b6159fa1aefc623a40 (patch)
treefe244d6178c8e291aad923e2b03ba0b3cb36ea2d /tests/Makefile.am
parentb0099f8f5ce53544a225033274ffd692e9edf4e6 (diff)
downloadlibdbusmenu-b29f86be192fda821b7245b6159fa1aefc623a40.tar.gz
libdbusmenu-b29f86be192fda821b7245b6159fa1aefc623a40.tar.bz2
libdbusmenu-b29f86be192fda821b7245b6159fa1aefc623a40.zip
Adding in a new gtester test suite.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am32
1 files changed, 31 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index cfa1399..6482d09 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -7,6 +7,7 @@ TESTS = \
test-glib-properties \
test-glib-proxy \
test-glib-simple-items \
+ test-gtk-objects-test \
test-gtk-label \
test-gtk-reorder
@@ -20,6 +21,7 @@ check_PROGRAMS = \
test-glib-proxy-client \
test-glib-proxy-server \
test-glib-proxy-proxy \
+ test-gtk-objects \
test-gtk-label-client \
test-gtk-label-server \
test-glib-simple-items \
@@ -196,6 +198,33 @@ test_glib_simple_items_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+######################
+# Test GTK Object
+######################
+
+GTK_OBJECT_XML_REPORT = test-gtk-objects.xml
+
+test-gtk-objects-test: test-gtk-objects Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo $(DBUS_RUNNER) --task gtester --parameter --verbose --parameter -k --parameter -o --parameter $(GTK_OBJECT_XML_REPORT) --parameter ./test-gtk-objects >> $@
+ @chmod +x $@
+
+test_gtk_objects_SOURCES = \
+ test-gtk-objects.c
+
+test_gtk_objects_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) \
+ $(DBUSMENUGTK_CFLAGS) \
+ -Wall -Werror
+
+test_gtk_objects_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGLIB_LIBS) \
+ $(DBUSMENUGTK_LIBS)
+
#########################
# Test GTK Label
#########################
@@ -322,5 +351,6 @@ distclean-local:
DISTCLEANFILES = \
$(TESTS) \
- $(OBJECT_XML_REPORT)
+ $(OBJECT_XML_REPORT) \
+ $(GTK_OBJECT_XML_REPORT)