aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-10 16:43:33 -0400
committerTed Gould <ted@canonical.com>2009-10-10 16:43:33 -0400
commitbba2d0aecb9ac87a822f343cad0f55002ed96dd6 (patch)
tree29db748ecb846efdf3bddfc7a6c70c1473cf99f5 /tests/Makefile.am
parent3912706e8bbfb7c0d33b7dff126a8c4ad6b110d1 (diff)
downloadlibdbusmenu-bba2d0aecb9ac87a822f343cad0f55002ed96dd6.tar.gz
libdbusmenu-bba2d0aecb9ac87a822f343cad0f55002ed96dd6.tar.bz2
libdbusmenu-bba2d0aecb9ac87a822f343cad0f55002ed96dd6.zip
Adding in basic xvfb stuff, doesn't quite work.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am31
1 files changed, 30 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 10fe857..833c3fc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,6 @@
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
TESTS = \
- test-mago \
test-glib-layout \
test-glib-properties \
test-gtk-label \
@@ -20,6 +19,33 @@ check_PROGRAMS = \
test-glib-simple-items \
test-gtk-reorder-server
+check-local: test-mago-xvfb
+
+######################
+# Xvfb server stuff
+######################
+
+XVFB = Xvfb -ac -noreset -screen 0 800x600x16
+XIDS = 101 102 103 104 105 106 107 197 199 211 223 227 293 307 308 309 310 311 \
+ 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 \
+ 991 992 993 994 995 996 997 998 999 1000 1001 1002 1003 1004 1005 1006 1007 \
+ 1008 1009 4703 4721 4723 4729 4733 4751 9973 9974 9975 9976 9977 9978 9979 \
+ 9980 9981 9982 9983 9984 9985 9986 9987 9988 9989 9990 9991 9992 9993 9994 \
+ 9995 9996 9997 9998 9999
+XVFB_START = \
+ ${XVFB} -help 2>/dev/null 1>&2 \
+ && XID=`for id in $(XIDS) ; do test -e /tmp/.X$$id-lock || { echo $$id; exit 0; }; done; exit 1` \
+ && { ${XVFB} :$$XID -screen 0 800x600x16 -nolisten tcp -auth /dev/null >/dev/null 2>&1 & \
+ trap "kill -15 $$! " 0 HUP INT QUIT TRAP USR1 PIPE TERM ; } \
+ || { echo "Gtk+Tests:ERROR: Failed to start Xvfb environment for X11 target tests."; exit 1; } \
+ && DISPLAY=:$$XID && export DISPLAY
+# call as: $(XVFB_START) && someprogram
+
+
+######################
+# Test GLib server
+######################
+
glib_server_nomenu_SOURCES = \
glib-server-nomenu.c
@@ -180,6 +206,9 @@ test_gtk_reorder_server_LDADD = \
# Test Mago
#########################
+test-mago-xvfb: test-mago
+ $(XVFB_START) && ./test-mago
+
test-mago: test-gtk-label-client test-gtk-label-server $(srcdir)/dbusmenu-gtk/mago_tests/dbusmenu.xml Makefile.am
@echo "#!/bin/sh" > test-mago
@echo cd $(srcdir)/dbusmenu-gtk >> test-mago