aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-05-25 00:06:22 +0200
committerTed Gould <ted@canonical.com>2009-05-25 00:06:22 +0200
commitc77c0f5b854bb2b924b98a09f598db66de0ab5e4 (patch)
treeea4b8f24f37e63bff44d4ce3235dca1368653566 /tests/Makefile.am
parenta3e5b5d4e8b5f0919039a94d9e05b484dc8b0c67 (diff)
downloadlibdbusmenu-c77c0f5b854bb2b924b98a09f598db66de0ab5e4.tar.gz
libdbusmenu-c77c0f5b854bb2b924b98a09f598db66de0ab5e4.tar.bz2
libdbusmenu-c77c0f5b854bb2b924b98a09f598db66de0ab5e4.zip
Building up the gtk tests. Oops, should have committed these a while ago.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am39
1 files changed, 37 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1f21141..70750ac 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,14 +2,16 @@ check: tests
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
-tests: test-glib-layout test-glib-properties
+tests: test-glib-layout test-glib-properties test-gtk-label
libexec_PROGRAMS = \
glib-server-nomenu \
test-glib-layout-client \
test-glib-layout-server \
test-glib-properties-client \
- test-glib-properties-server
+ test-glib-properties-server \
+ test-gtk-label-client \
+ test-gtk-label-server
glib_server_nomenu_SOURCES = \
glib-server-nomenu.c
@@ -82,6 +84,39 @@ test_glib_properties_client_LDADD = \
+test-gtk-label: test-gtk-label-client test-gtk-label-server
+ $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --task-name Server --ignore-return
+
+test_gtk_label_server_SOURCES = \
+ test-gtk-label.h \
+ test-gtk-label-server.c
+
+test_gtk_label_server_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_gtk_label_server_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGTK_LIBS)
+
+test_gtk_label_client_SOURCES = \
+ test-gtk-label.h \
+ test-gtk-label-client.c
+
+test_gtk_label_client_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGTK_CFLAGS) \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_gtk_label_client_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGTK_LIBS)
+
+
+
examplesdir = $(docdir)/examples/
examples_DATA = \