aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-11-19 17:21:55 -0600
committerTed Gould <ted@canonical.com>2009-11-19 17:21:55 -0600
commitd8427db9d5559e49bbec99f0bd01aaeafa82b347 (patch)
tree2a102e11d0e4502e0cace48c20449537d31c0735 /tests/Makefile.am
parent4cdbbb71476d5f3b6979f6cd43acf3b1ea1f1004 (diff)
downloadlibdbusmenu-d8427db9d5559e49bbec99f0bd01aaeafa82b347.tar.gz
libdbusmenu-d8427db9d5559e49bbec99f0bd01aaeafa82b347.tar.bz2
libdbusmenu-d8427db9d5559e49bbec99f0bd01aaeafa82b347.zip
Switching to Bash
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3443073..8523b06 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -44,7 +44,7 @@ glib_server_nomenu_LDADD = \
######################
test-glib-layout: test-glib-layout-client test-glib-layout-server Makefile.am
- @echo "#!/bin/sh" > test-glib-layout
+ @echo "#!/bin/bash" > test-glib-layout
@echo $(DBUS_RUNNER) --task ./test-glib-layout-client --task-name Client --task ./test-glib-layout-server --task-name Server --ignore-return >> test-glib-layout
@chmod +x test-glib-layout
@@ -78,7 +78,7 @@ test_glib_layout_client_LDADD = \
######################
test-glib-properties: test-glib-properties-client test-glib-properties-server Makefile.am
- @echo "#!/bin/sh" > test-glib-properties
+ @echo "#!/bin/bash" > test-glib-properties
@echo $(DBUS_RUNNER) --task ./test-glib-properties-client --task-name Client --task ./test-glib-properties-server --task-name Server --ignore-return >> test-glib-properties
@chmod +x test-glib-properties
@@ -126,7 +126,7 @@ test_glib_simple_items_LDADD = \
#########################
test-gtk-label: test-gtk-label-client test-gtk-label-server test-gtk-label.json Makefile.am
- @echo "#!/bin/sh" > test-gtk-label
+ @echo "#!/bin/bash" > test-gtk-label
@echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> test-gtk-label
@chmod +x test-gtk-label
@@ -165,7 +165,7 @@ test_gtk_label_client_LDADD = \
#########################
test-gtk-reorder: test-gtk-label-client test-gtk-reorder-server Makefile.am
- @echo "#!/bin/sh" > test-gtk-reorder
+ @echo "#!/bin/bash" > test-gtk-reorder
@echo $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-reorder-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return >> test-gtk-reorder
@chmod +x test-gtk-reorder
@@ -189,7 +189,7 @@ test_gtk_reorder_server_LDADD = \
#########################
test-mago: test-gtk-label-client test-gtk-label-server $(srcdir)/dbusmenu-gtk/mago_tests/dbusmenu.xml Makefile.am
- @echo "#!/bin/sh" > $@
+ @echo "#!/bin/bash" > $@
@echo $(XVFB_RUN) >> $@
@echo cd $(srcdir)/dbusmenu-gtk >> $@
@echo /usr/lib/at-spi/at-spi-registryd \& >> $@