aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin@piware.de>2011-02-21 13:12:33 +0100
committerMartin Pitt <martin@piware.de>2011-02-21 13:12:33 +0100
commitded5bb1e7c5bf42c24ed25a66c7e73ae8eaa54e0 (patch)
treeeeac4c7bace411463570b6d0b06b18264d09afe8 /tests/Makefile.am
parent3f3db4e1ea5e5b2321a7266edf018bb510fcdfb4 (diff)
parent87703b408d42ce97b5a64142b0c33951d366890a (diff)
downloadlibdbusmenu-ded5bb1e7c5bf42c24ed25a66c7e73ae8eaa54e0.tar.gz
libdbusmenu-ded5bb1e7c5bf42c24ed25a66c7e73ae8eaa54e0.tar.bz2
libdbusmenu-ded5bb1e7c5bf42c24ed25a66c7e73ae8eaa54e0.zip
merge trunk
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9259ed1..c0081b0 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@
DBUS_RUNNER=dbus-test-runner
CLEANFILES=
+DISTCLEANFILES=
TESTS = \
test-glib-objects-test \
@@ -264,6 +265,8 @@ test_glib_objects_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+DISTCLEANFILES += $(OBJECT_XML_REPORT)
+
######################
# Test Glib Properties
######################
@@ -390,6 +393,8 @@ test_gtk_objects_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+DISTCLEANFILES += $(GTK_OBJECT_XML_REPORT)
+
######################
# Test GTK Parser
######################
@@ -418,6 +423,7 @@ test_gtk_parser_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+DISTCLEANFILES += $(GTK_PARSER_XML_REPORT)
#########################
# Test GTK Label
@@ -626,8 +632,6 @@ CLEANFILES += \
distclean-local:
-rm -rf $(builddir)/mago.results
-DISTCLEANFILES = \
- $(filter-out %.py, $(TESTS)) \
- $(OBJECT_XML_REPORT) \
- $(GTK_OBJECT_XML_REPORT)
+DISTCLEANFILES += \
+ $(filter-out %.py, $(TESTS))