aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-06-17 16:36:17 -0500
committerTed Gould <ted@canonical.com>2009-06-17 16:36:17 -0500
commite685fa4eed5c4fcbc469e3ebe2a9c6562c91b057 (patch)
tree0b099ce1b0e7a366f1a2f24409f39a76e050c56a /tests/Makefile.am
parent07b578064af5b24176c86e002cf410adebe99626 (diff)
downloadlibdbusmenu-e685fa4eed5c4fcbc469e3ebe2a9c6562c91b057.tar.gz
libdbusmenu-e685fa4eed5c4fcbc469e3ebe2a9c6562c91b057.tar.bz2
libdbusmenu-e685fa4eed5c4fcbc469e3ebe2a9c6562c91b057.zip
The new dbus-test-runner has parameters. So now we're changing the server to take the json parameter and the file.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e566594..2ec6ca7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -84,8 +84,8 @@ test_glib_properties_client_LDADD = \
-test-gtk-label: test-gtk-label-client test-gtk-label-server
- $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --task-name Server --ignore-return
+test-gtk-label: test-gtk-label-client test-gtk-label-server test-gtk-label.json
+ $(DBUS_RUNNER) --task ./test-gtk-label-client --task-name Client --task ./test-gtk-label-server --parameter $(srcdir)/test-gtk-label.json --task-name Server --ignore-return
test_gtk_label_server_SOURCES = \
test-gtk-label-server.c
@@ -124,4 +124,6 @@ examplesdir = $(docdir)/examples/
examples_DATA = \
$(glib_server_nomenu_SOURCES)
-EXTRA_DIST = $(examples_DATA)
+EXTRA_DIST = \
+ $(examples_DATA) \
+ test-gtk-label.json