aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-06-05 15:08:56 -0500
committerTed Gould <ted@canonical.com>2009-06-05 15:08:56 -0500
commitec5c382624da19a1a83d1e75d21f74778df01f38 (patch)
treeab9fcd33632bf90eb6374408a6d4bb2e4a9050e3 /tests/Makefile.am
parent3d0e0276fd7856831dcc845a24a252ad304b3bad (diff)
parent3c9734543b84ecd412ffd214ac0560b11858a00a (diff)
downloadlibdbusmenu-ec5c382624da19a1a83d1e75d21f74778df01f38.tar.gz
libdbusmenu-ec5c382624da19a1a83d1e75d21f74778df01f38.tar.bz2
libdbusmenu-ec5c382624da19a1a83d1e75d21f74778df01f38.zip
Merging in work on properties. Cody reviewed in merge request 6707.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am38
1 files changed, 36 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ca0bd77..1f21141 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,12 +2,14 @@ check: tests
DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
-tests: test-glib-layout
+tests: test-glib-layout test-glib-properties
libexec_PROGRAMS = \
glib-server-nomenu \
test-glib-layout-client \
- test-glib-layout-server
+ test-glib-layout-server \
+ test-glib-properties-client \
+ test-glib-properties-server
glib_server_nomenu_SOURCES = \
glib-server-nomenu.c
@@ -20,10 +22,13 @@ glib_server_nomenu_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+
+
test-glib-layout: test-glib-layout-client test-glib-layout-server
$(DBUS_RUNNER) --task ./test-glib-layout-client --task-name Client --task ./test-glib-layout-server --task-name Server --ignore-return
test_glib_layout_server_SOURCES = \
+ test-glib-layout.h \
test-glib-layout-server.c
test_glib_layout_server_CFLAGS = \
@@ -35,6 +40,7 @@ test_glib_layout_server_LDADD = \
$(DBUSMENUGLIB_LIBS)
test_glib_layout_client_SOURCES = \
+ test-glib-layout.h \
test-glib-layout-client.c
test_glib_layout_client_CFLAGS = \
@@ -47,6 +53,34 @@ test_glib_layout_client_LDADD = \
+test-glib-properties: test-glib-properties-client test-glib-properties-server
+ $(DBUS_RUNNER) --task ./test-glib-properties-client --task-name Client --task ./test-glib-properties-server --task-name Server --ignore-return
+
+test_glib_properties_server_SOURCES = \
+ test-glib-properties.h \
+ test-glib-properties-server.c
+
+test_glib_properties_server_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_glib_properties_server_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS)
+
+test_glib_properties_client_SOURCES = \
+ test-glib-properties.h \
+ test-glib-properties-client.c
+
+test_glib_properties_client_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+test_glib_properties_client_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS)
+
+
examplesdir = $(docdir)/examples/