aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-03-27 15:11:33 -0500
committerTed Gould <ted@gould.cx>2012-03-27 15:11:33 -0500
commitef80236d7f7f501eb9bfef9f5de2d914d4db534f (patch)
tree20b68d1af5a75f9888915f520f845fc1f3b4bf06 /tests/Makefile.am
parent4dd014ca94bd0a47cece8fcc1cf978431adc2888 (diff)
downloadlibdbusmenu-ef80236d7f7f501eb9bfef9f5de2d914d4db534f.tar.gz
libdbusmenu-ef80236d7f7f501eb9bfef9f5de2d914d4db534f.tar.bz2
libdbusmenu-ef80236d7f7f501eb9bfef9f5de2d914d4db534f.zip
Using the new --wait-for attribute of dbus-test-runner
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6824c1c..16f00c5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -208,7 +208,7 @@ test-json: test-json-client test-json-server Makefile.am
@echo export UBUNTU_MENUPROXY="" >> $@
@echo export G_DEBUG=fatal_criticals >> $@
@echo $(XVFB_RUN) >> $@
- @echo $(DBUS_RUNNER) --task ./test-json-client --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter test-json-01.output.json --ignore-return --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json --ignore-return >> $@
+ @echo $(DBUS_RUNNER) --task ./test-json-client --wait-for org.dbusmenu.test --task-name Client --parameter $(top_builddir)/tools/dbusmenu-dumper --parameter test-json-01.output.json --ignore-return --task ./test-json-server --task-name Server --parameter $(srcdir)/test-json-01.json --ignore-return >> $@
@echo diff $(srcdir)/test-json-01.json test-json-01.output.json \> /dev/null >> $@
@chmod +x $@