aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-02-21 10:18:48 -0600
committerTed Gould <ted@gould.cx>2011-02-21 10:18:48 -0600
commitf3eb3cbb4623b9e996d2cc62a21b6fcc4a2331c7 (patch)
tree4bafd846379e19c9b2ac31d940ecbdd3d460811e /tests/Makefile.am
parent18c5f32b393ada7a3a7507b0a83bbd98f88a1722 (diff)
downloadlibdbusmenu-f3eb3cbb4623b9e996d2cc62a21b6fcc4a2331c7.tar.gz
libdbusmenu-f3eb3cbb4623b9e996d2cc62a21b6fcc4a2331c7.tar.bz2
libdbusmenu-f3eb3cbb4623b9e996d2cc62a21b6fcc4a2331c7.zip
Fixing distcheck by including py file and cleaning up it's pyc
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f9102ed..1f8faec 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,6 +3,7 @@ DBUS_RUNNER=dbus-test-runner
CLEANFILES=
DISTCLEANFILES=
+EXTRA_DIST =
TESTS = \
test-glib-objects-test \
@@ -477,12 +478,6 @@ test-gtk-shortcut: test-gtk-shortcut-client test-gtk-shortcut-server Makefile.am
@echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
@chmod +x $@
-test-gtk-shortcut-python: test-gtk-shortcut-server Makefile.am
- @echo "#!/bin/bash" > $@
- @echo $(XVFB_RUN) >> $@
- @echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client.py --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
- @chmod +x $@
-
test_gtk_shortcut_server_SOURCES = \
test-gtk-shortcut-server.c
@@ -514,6 +509,19 @@ test_gtk_shortcut_client_LDADD = \
$(DBUSMENUTESTS_LIBS)
#########################
+# Test GTK Shortcut Python
+#########################
+
+test-gtk-shortcut-python: test-gtk-shortcut-server test-gtk-shortcut-client.py Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo $(DBUS_RUNNER) --task ./test-gtk-shortcut-client.py --task-name Client --task ./test-gtk-shortcut-server --task-name Server --ignore-return >> $@
+ @chmod +x $@
+
+EXTRA_DIST += test-gtk-shortcut-client.py
+CLEANFILES += test-gtk-shortcut-client.pyc
+
+#########################
# Test GTK Reorder
#########################
@@ -607,7 +615,7 @@ jsondir = $(datadir)/${PACKAGE}/json/
json_DATA = \
test-gtk-label.json
-EXTRA_DIST = \
+EXTRA_DIST += \
$(examples_DATA) \
run-xvfb.sh \
$(json_DATA) \