aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-02-15 15:06:42 -0600
committerTed Gould <ted@gould.cx>2011-02-15 15:06:42 -0600
commitfd71ffff45749bc72cabcd4c5fd8b258d7d25c72 (patch)
tree5abc0397e8d53565b78dd2cfc6fe0b1878380998 /tests/Makefile.am
parent5c1bbec8381af0246b813a095f816b55e2f8dc06 (diff)
downloadlibdbusmenu-fd71ffff45749bc72cabcd4c5fd8b258d7d25c72.tar.gz
libdbusmenu-fd71ffff45749bc72cabcd4c5fd8b258d7d25c72.tar.bz2
libdbusmenu-fd71ffff45749bc72cabcd4c5fd8b258d7d25c72.zip
Make sure to clean up the reports
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 62142dc..32c8437 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@
DBUS_RUNNER=dbus-test-runner
CLEANFILES=
+DISTCLEANFILES=
TESTS = \
test-glib-objects-test \
@@ -260,6 +261,8 @@ test_glib_objects_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+DISTCLEANFILES += $(OBJECT_XML_REPORT)
+
######################
# Test Glib Properties
######################
@@ -386,6 +389,8 @@ test_gtk_objects_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+DISTCLEANFILES += $(GTK_OBJECT_XML_REPORT)
+
######################
# Test GTK Parser
######################
@@ -414,6 +419,7 @@ test_gtk_parser_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+DISTCLEANFILES += $(GTK_PARSER_XML_REPORT)
#########################
# Test GTK Label
@@ -622,8 +628,6 @@ CLEANFILES += \
distclean-local:
-rm -rf $(builddir)/mago.results
-DISTCLEANFILES = \
- $(TESTS) \
- $(OBJECT_XML_REPORT) \
- $(GTK_OBJECT_XML_REPORT)
+DISTCLEANFILES += \
+ $(TESTS)