aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-01-23 13:30:00 -0600
committerTed Gould <ted@gould.cx>2011-01-23 13:30:00 -0600
commitfda2b25645a35ec7b3baddc366e483a8a9b83e58 (patch)
tree6a5138b60719ce82bbf10278dddee975751dd01f /tests/Makefile.am
parent401bc7c326c518ad01c1edd38155d89d9e35fd49 (diff)
downloadlibdbusmenu-fda2b25645a35ec7b3baddc366e483a8a9b83e58.tar.gz
libdbusmenu-fda2b25645a35ec7b3baddc366e483a8a9b83e58.tar.bz2
libdbusmenu-fda2b25645a35ec7b3baddc366e483a8a9b83e58.zip
Adding in a basic test that just ensures the parser isn't entirely broken
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am35
1 files changed, 33 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 17b44d1..62142dc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,7 +16,8 @@ TESTS = \
test-gtk-label \
test-gtk-shortcut \
test-gtk-reorder \
- test-gtk-submenu
+ test-gtk-submenu \
+ test-gtk-parser-test
check_PROGRAMS = \
glib-server-nomenu \
@@ -42,7 +43,8 @@ check_PROGRAMS = \
test-json-client \
test-json-server \
test-gtk-submenu-server \
- test-gtk-submenu-client
+ test-gtk-submenu-client \
+ test-gtk-parser
XVFB_RUN=". $(srcdir)/run-xvfb.sh"
@@ -384,6 +386,35 @@ test_gtk_objects_LDADD = \
$(DBUSMENUGLIB_LIBS) \
$(DBUSMENUGTK_LIBS)
+######################
+# Test GTK Parser
+######################
+
+GTK_PARSER_XML_REPORT = test-gtk-parser.xml
+
+test-gtk-parser-test: test-gtk-parser Makefile.am
+ @echo "#!/bin/bash" > $@
+ @echo $(XVFB_RUN) >> $@
+ @echo gtester --verbose -k -o $(GTK_PARSER_XML_REPORT) ./test-gtk-parser >> $@
+ @chmod +x $@
+
+test_gtk_parser_SOURCES = \
+ test-gtk-parser.c
+
+test_gtk_parser_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) \
+ $(DBUSMENUGTK_CFLAGS) \
+ -DSRCDIR="\"$(srcdir)\"" \
+ -Wall -Werror
+
+test_gtk_parser_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ ../libdbusmenu-gtk/libdbusmenu-gtk.la \
+ $(DBUSMENUGLIB_LIBS) \
+ $(DBUSMENUGTK_LIBS)
+
+
#########################
# Test GTK Label
#########################