aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-10-05 10:12:45 -0400
committerTed Gould <ted@canonical.com>2009-10-05 10:12:45 -0400
commit3f56fb5dd3989a6926d6285345df8d71f9053924 (patch)
tree7746e0c915942b21e4be1186f10ae5c8b6c5f067 /tools/Makefile.am
parent2b1220bd8455a79ff0f3da340cf9337c159d1720 (diff)
downloadlibdbusmenu-3f56fb5dd3989a6926d6285345df8d71f9053924.tar.gz
libdbusmenu-3f56fb5dd3989a6926d6285345df8d71f9053924.tar.bz2
libdbusmenu-3f56fb5dd3989a6926d6285345df8d71f9053924.zip
A stub dbusmenu dumper
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 7299564..415050f 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,3 +1,14 @@
-# Stuff will go here.
+libexec_PROGRAMS = dbusmenu-dumper
+
+dbusmenu_dumper_SOURCES = \
+ dbusmenu-dumper.c
+
+dbusmenu_dumper_CFLAGS = \
+ -I $(srcdir)/.. \
+ $(DBUSMENUGLIB_CFLAGS) -Wall -Werror
+
+dbusmenu_dumper_LDADD = \
+ ../libdbusmenu-glib/libdbusmenu-glib.la \
+ $(DBUSMENUGLIB_LIBS)