aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c2c0980..6b11b31 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,13 +1,23 @@
+ACLOCAL_AMFLAGS = -I m4
+
EXTRA_DIST = \
COPYING.2.1 \
COPYING-GPL3 \
m4/introspection.m4
+if WANT_TESTS
+TESTS_SUBDIR = tests
+endif
+
+if WANT_LIBDBUSMENUGTK
+LIBDBUSMENUGTK_SUBDIR = libdbusmenu-gtk
+endif
+
SUBDIRS = \
libdbusmenu-glib \
- libdbusmenu-gtk \
+ $(LIBDBUSMENUGTK_SUBDIR) \
tools \
- tests \
+ $(TESTS_SUBDIR) \
docs \
po