aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a46901f..be12b31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,18 @@ if test "x$with_massivedebugging" = "xyes"; then
fi
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -251,3 +263,7 @@ AS_IF([test "x$have_dumper" = "xyes"],
AC_MSG_NOTICE([ Dumper: no])
)
+AS_IF([test "x$use_gcov" = "xyes"],
+ AC_MSG_NOTICE([ Coverage reporting: yes]),
+ AC_MSG_NOTICE([ Coverage reporting: no])
+)