aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a80f1d1..4f52706 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,8 @@
+check: tests
+
+DBUS_RUNNER=dbus-test-runner --dbus-config /usr/share/dbus-test-runner/session.conf
+
+tests: test-glib-layout
libexec_PROGRAMS = \
glib-server-nomenu \
@@ -15,6 +20,9 @@ glib_server_nomenu_LDADD = \
../libdbusmenu-glib/libdbusmenu-glib.la \
$(DBUSMENUGLIB_LIBS)
+test-glib-layout: test-glib-layout-client test-glib-layout-server
+ $(DBUS_RUNNER) --task ./test-glib-layout-client --task ./test-glib-layout-server
+
test_glib_layout_server_SOURCES = \
test-glib-layout-server.c