aboutsummaryrefslogtreecommitdiff
path: root/tools/testapp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testapp/CMakeLists.txt')
-rw-r--r--tools/testapp/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tools/testapp/CMakeLists.txt b/tools/testapp/CMakeLists.txt
new file mode 100644
index 0000000..b848e50
--- /dev/null
+++ b/tools/testapp/CMakeLists.txt
@@ -0,0 +1,29 @@
+find_package(PkgConfig REQUIRED)
+
+pkg_check_modules(DBUSMENUGLIB REQUIRED dbusmenu-glib)
+pkg_check_modules(GLIB REQUIRED glib-2.0)
+pkg_check_modules(JSONGLIB REQUIRED json-glib-1.0)
+
+set(glibapp_SRCS
+ main.c
+ )
+
+include_directories(
+ ${DBUSMENUGLIB_INCLUDE_DIRS}
+ ${GLIB_INCLUDE_DIRS}
+ ${JSONGLIB_INCLUDE_DIRS}
+ )
+
+link_directories(
+ ${DBUSMENUGLIB_LIBRARY_DIRS}
+ ${GLIB_LIBRARY_DIRS}
+ ${JSONGLIB_LIBRARY_DIRS}
+ )
+
+add_executable(dbusmenubench-glibapp ${glibapp_SRCS})
+
+target_link_libraries(dbusmenubench-glibapp
+ ${DBUSMENUGLIB_LIBRARIES}
+ ${GLIB_LIBARIES}
+ ${JSONGLIB_LIBRARIES}
+ )