aboutsummaryrefslogtreecommitdiff
path: root/tools/testapp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testapp/Makefile.am')
-rw-r--r--tools/testapp/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/tools/testapp/Makefile.am b/tools/testapp/Makefile.am
index 39de532..e2bbde7 100644
--- a/tools/testapp/Makefile.am
+++ b/tools/testapp/Makefile.am
@@ -1,11 +1,9 @@
-if USE_GTK3
-VER=3
-else
-VER=
-endif
+libexec_PROGRAMS =
-libexec_PROGRAMS = dbusmenu-testapp
+if WANT_TESTS
+libexec_PROGRAMS += dbusmenu-testapp
+endif
dbusmenu_testapp_SOURCES = \
main.c
@@ -18,6 +16,4 @@ dbusmenu_testapp_CFLAGS = \
dbusmenu_testapp_LDADD = \
$(builddir)/../../libdbusmenu-glib/libdbusmenu-glib.la \
- $(builddir)/../../libdbusmenu-gtk/libdbusmenu-gtk$(VER).la \
- $(DBUSMENUGTK_LIBS) \
$(DBUSMENUTESTS_LIBS)