aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-09-20 08:39:53 +0000
committerTarmac <Unknown>2012-09-20 08:39:53 +0000
commit126edd829bbf88c1a2a186a874acb4a307f3b5a9 (patch)
tree877c48d3bef1123accafba2caa953d73bc2002c5 /configure.ac
parentaa87c8fac598ef6e79a65d6f2eec93d8a4693063 (diff)
parent19c01abdd2c3a3d772cf8b7f54b819231ac4dcba (diff)
downloadlibpam-freerdp2-126edd829bbf88c1a2a186a874acb4a307f3b5a9.tar.gz
libpam-freerdp2-126edd829bbf88c1a2a186a874acb4a307f3b5a9.tar.bz2
libpam-freerdp2-126edd829bbf88c1a2a186a874acb4a307f3b5a9.zip
Adding a testing framework. Approved by Albert Astals Cid, jenkins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa8a3f9..cee665d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,8 @@ AM_INIT_AUTOMAKE([1.11 -Wno-portability])
AM_SILENT_RULES([yes])
AC_PROG_CC
+# the Google Test targets are cpp
+AC_PROG_CXX
AC_PROG_LIBTOOL
LT_INIT([disable-static])
@@ -46,9 +48,34 @@ else
fi
AC_SUBST(PAMMODULEDIR)
+###########################
+# Google Test Dependencies
+###########################
+
+m4_include([m4/gtest.m4])
+CHECK_GTEST
+if test "x$have_gtest" != "xyes"; then
+ AC_MSG_ERROR([tests were requested but gtest is not installed.])
+fi
+
+###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+
AC_CONFIG_FILES([
Makefile
src/Makefile
+ tests/Makefile
])
AC_OUTPUT