aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBernhard Miklautz <bernhard.miklautz@shacknet.at>2017-12-18 12:44:54 +0100
committerBernhard Miklautz <bernhard.miklautz@shacknet.at>2017-12-18 12:53:19 +0100
commit5583d6a2d86038bdeceb99e4752f961147dd585b (patch)
tree2b78f9afb046a10586bc3c1a678501e33035b392 /src/Makefile.am
parentea05a6160c17460f8cdde00ac35f6023e47dd6a7 (diff)
downloadlibpam-freerdp2-5583d6a2d86038bdeceb99e4752f961147dd585b.tar.gz
libpam-freerdp2-5583d6a2d86038bdeceb99e4752f961147dd585b.tar.bz2
libpam-freerdp2-5583d6a2d86038bdeceb99e4752f961147dd585b.zip
Update to use the freerdp2 API
* use the new API * use AuthenticationOnly * return 0 on SUCCESS the last known error otherwise * disable wlog output (unless compiled with ENABLE_WLOG)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ab46225..4eb3aa0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,9 +39,12 @@ freerdp2_auth_check_SOURCES = \
freerdp-auth-check.c
freerdp2_auth_check_CFLAGS = \
$(FREERDP2_CFLAGS) \
+ $(WINPR2_CFLAGS) \
$(COVERAGE_CFLAGS)
freerdp2_auth_check_LDADD = \
- $(FREERDP2_LIBS)
+ $(FREERDP2_LIBS) \
+ $(WINPR2_LIBS)
freerdp2_auth_check_LDFLAGS = \
$(FREERDP2_LDFLAGS) \
+ $(WINPR2_LDFLAGS) \
$(COVERAGE_LDFLAGS)