aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-09-20 08:39:53 +0000
committerTarmac <>2012-09-20 08:39:53 +0000
commit6af8fab5b1df788bc57e5d174fc090824c9c0065 (patch)
tree877c48d3bef1123accafba2caa953d73bc2002c5 /configure.ac
parent84fb97ec2326559940bafd6f7a7b1370fb679d86 (diff)
parent74540195ac67a579ba0f8a2479cfcadb6bee6cc8 (diff)
downloadlibpam-x2go-6af8fab5b1df788bc57e5d174fc090824c9c0065.tar.gz
libpam-x2go-6af8fab5b1df788bc57e5d174fc090824c9c0065.tar.bz2
libpam-x2go-6af8fab5b1df788bc57e5d174fc090824c9c0065.zip
Adding a testing framework. Approved by Albert Astals Cid, jenkins.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa8a3f9..cee665d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,8 @@ AM_INIT_AUTOMAKE([1.11 -Wno-portability])
AM_SILENT_RULES([yes])
AC_PROG_CC
+# the Google Test targets are cpp
+AC_PROG_CXX
AC_PROG_LIBTOOL
LT_INIT([disable-static])
@@ -46,9 +48,34 @@ else
fi
AC_SUBST(PAMMODULEDIR)
+###########################
+# Google Test Dependencies
+###########################
+
+m4_include([m4/gtest.m4])
+CHECK_GTEST
+if test "x$have_gtest" != "xyes"; then
+ AC_MSG_ERROR([tests were requested but gtest is not installed.])
+fi
+
+###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+
AC_CONFIG_FILES([
Makefile
src/Makefile
+ tests/Makefile
])
AC_OUTPUT